{"answers":{"affected":"It affects 6 products.","exploited":"There is no known exploitation of CVE-2014-8104 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-8104 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 3 Dec 2014. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-8104 and fix it if it is affected.\n\nWhat it is: CVE-2014-8104 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 3 Dec 2014. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-8104 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-8104/ (Markdown: https://insights.sbomify.com/CVE-2014-8104/index.md)","id":"CVE-2014-8104","markdown":"https://insights.sbomify.com/CVE-2014-8104/index.md","name":"CVE-2014-8104","record":{"aliases":["DEBIAN-CVE-2014-8104","DLA-98-1","DSA-3084-1","GHSA-p2qj-cw7j-f6wr","MGASA-2014-0512","UBUNTU-CVE-2014-8104","USN-2430-1","openSUSE-SU-2024:10211-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenVPN server","requires_auth":"low_privilege","summary":"Remote authenticated users can crash the OpenVPN server by sending a small control channel packet, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"mageia","vendor":"mageia"},{"product":"opensuse","vendor":"opensuse"},{"product":"openvpn","vendor":"openvpn"},{"product":"openvpn_access_server","vendor":"openvpn"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:S/C:N/I:N/A:C","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"OpenVPN 2.x before 2.0.11, 2.1.x, 2.2.x before 2.2.3, and 2.3.x before 2.3.6 allows remote authenticated users to cause a denial of service (server crash) via a small control channel packet.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2014-8104","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","opensuse:opensuse"],"type":"denial_of_service","year":"2014"},"n_packages":1,"n_references":6,"next":{"headline":"Information disclosure in n/a","id":"CVE-2014-8105"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.3.11-3.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/opensuse/openvpn\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10211-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2014-8103"},"products":["n/a"],"published":"2014-12-03","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote authenticated users can crash the OpenVPN server by sending a small control channel packet, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2014-8104/"}