# CVE-2014-8110: Improper Neutralization of Input During Web Page Generation in Apache ActiveMQ

> Remote attackers can inject arbitrary web script or HTML into the Apache ActiveMQ administration console, potentially compromising administrator sessions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Feb 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-9cvr-8xq4-2m73

## What is CVE-2014-8110?

CVE-2014-8110 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 12 Feb 2015. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in the web based administration console in Apache ActiveMQ 5.x before 5.10.1 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-8110?

2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.10.1 |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.10.1 |

Products: Apache Activemq.

## How do I fix CVE-2014-8110?

Upgrade org.apache.activemq:activemq-client to 5.10.1 or later.

## Is CVE-2014-8110 being exploited?

There is no known exploitation of CVE-2014-8110 in the wild and no public exploit code.

Public exploit code:

- https://github.com/tafamace/CVE-2014-8110 (github_poc): https://github.com/tafamace/CVE-2014-8110

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-8110 and fix it if it is affected.

What it is: CVE-2014-8110 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 12 Feb 2015. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-8110 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.10.1
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-8110/ (Markdown: https://insights.sbomify.com/CVE-2014-8110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-8110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-8110
- OSV: https://osv.dev/vulnerability/CVE-2014-8110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-8110/
Summaries are generated and may contain mistakes; the official description above is the record.
