# CVE-2014-8122: Information disclosure in JBoss Weld

> A race condition in JBoss Weld allows remote attackers to access information from previous conversations via stale thread state.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-338v-3958-8v8r

## What is CVE-2014-8122?

CVE-2014-8122 is a medium-severity vulnerability in n/a, published on 13 Feb 2015. It can be exploited over the network, with no action from the victim.

### Official description

Race condition in JBoss Weld before 2.2.8 and 3.x before 3.0.0 Alpha3 allows remote attackers to obtain information from a previous conversation via vectors related to a stale thread state.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2014-8122?

2 open source packages ship an affected version, including org.jboss.weld:weld-core-bom. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jboss.weld:weld-core-bom` | Maven | All versions | 2.2.8 |
| `org.jboss.weld:weld-core-bom` | Maven | All versions | 2.2.8 |

Products: Redhat Jboss Weld.

## How do I fix CVE-2014-8122?

Upgrade org.jboss.weld:weld-core-bom to 2.2.8 or later.

## Is CVE-2014-8122 being exploited?

There is no known exploitation of CVE-2014-8122 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-8122 and fix it if it is affected.

What it is: CVE-2014-8122 is a medium-severity vulnerability in n/a, published on 13 Feb 2015. It can be exploited over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-8122 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jboss.weld:weld-core-bom (Maven): affected all versions; fixed in 2.2.8
- org.jboss.weld:weld-core-bom (Maven): affected all versions; fixed in 2.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-8122/ (Markdown: https://insights.sbomify.com/CVE-2014-8122/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-8122
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-8122
- OSV: https://osv.dev/vulnerability/CVE-2014-8122

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-8122/
Summaries are generated and may contain mistakes; the official description above is the record.
