# CVE-2014-8125: Improper Input Validation in Drools and jBPM

> Remote attackers can read arbitrary files via crafted BPMN2 files in Drools and jBPM libraries due to an XML external entity vulnerability.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-6qx9-rf9g-7jmr

## What is CVE-2014-8125?

CVE-2014-8125 is a high-severity vulnerability in n/a, published on 21 Apr 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XML external entity (XXE) vulnerability in Drools and jBPM before 6.2.0 allows remote attackers to read arbitrary files or possibly have other unspecified impact via a crafted BPMN2 file.

## Which versions are affected by CVE-2014-8125?

4 open source packages ship an affected version, including org.drools:drools-core and org.jbpm:jbpm-bpmn2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.drools:drools-core` | Maven | All versions | 6.2.0.Final |
| `org.drools:drools-core` | Maven | All versions | 6.2.0.Final |
| `org.jbpm:jbpm-bpmn2` | Maven | All versions | 6.2.0.Final |
| `org.jbpm:jbpm-bpmn2` | Maven | All versions | 6.2.0.Final |

Products: Redhat Drools, Redhat Jbpm.

## How do I fix CVE-2014-8125?

Upgrade org.drools:drools-core to 6.2.0.Final or later.

## Is CVE-2014-8125 being exploited?

There is no known exploitation of CVE-2014-8125 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-41411](https://insights.sbomify.com/CVE-2021-41411/): XML External Entity Reference in drools (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-8125 and fix it if it is affected.

What it is: CVE-2014-8125 is a high-severity vulnerability in n/a, published on 21 Apr 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-8125 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.drools:drools-core (Maven): affected all versions; fixed in 6.2.0.Final
- org.drools:drools-core (Maven): affected all versions; fixed in 6.2.0.Final
- org.jbpm:jbpm-bpmn2 (Maven): affected all versions; fixed in 6.2.0.Final
- org.jbpm:jbpm-bpmn2 (Maven): affected all versions; fixed in 6.2.0.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-8125/ (Markdown: https://insights.sbomify.com/CVE-2014-8125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-8125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-8125
- OSV: https://osv.dev/vulnerability/CVE-2014-8125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-8125/
Summaries are generated and may contain mistakes; the official description above is the record.
