{"answers":{"affected":"2 open source packages ship an affected version, including doorkeeper. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-8144 in the wild and no public exploit code.","fix":"Upgrade doorkeeper to 1.4.1 or later.","what":"CVE-2014-8144 is a medium-severity vulnerability in n/a, published on 31 Dec 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-8144 and fix it if it is affected.\n\nWhat it is: CVE-2014-8144 is a medium-severity vulnerability in n/a, published on 31 Dec 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-8144 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- doorkeeper (RubyGems): affected all versions; fixed in 1.4.1\n- doorkeeper (RubyGems): affected all versions; fixed in 1.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-8144/ (Markdown: https://insights.sbomify.com/CVE-2014-8144/index.md)","id":"CVE-2014-8144","markdown":"https://insights.sbomify.com/CVE-2014-8144/index.md","name":"CVE-2014-8144","record":{"aliases":["GHSA-685w-vc84-wxcx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OAuth library","requires_auth":"low_privilege","summary":"Remote attackers can hijack user authentication to read OAuth authorization codes via CSRF, requiring victim interaction.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"doorkeeper","vendor":"doorkeeper_project"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote attackers to hijack the authentication of unspecified victims for requests that read a user OAuth authorization code via unknown vectors.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Doorkeeper vulnerable to Cross-site Request Forgery","id":"CVE-2014-8144","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2014"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2014-8145"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"doorkeeper","purl":null,"source":"GHSA-685w-vc84-wxcx"},{"ecosystem":"RubyGems","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"doorkeeper","purl":"pkg:gem/doorkeeper","source":"GHSA-685w-vc84-wxcx"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2014-8143"},"products":["n/a"],"published":"2014-12-31","related":[{"cvss_score":9.1,"headline":"Doorkeeper is vulnerable to replay attacks","id":"CVE-2016-6582","kev_date_added":null,"published":"2017-01-23"},{"cvss_score":7.5,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper","id":"CVE-2020-10187","kev_date_added":null,"published":"2020-05-04"},{"cvss_score":7.5,"headline":"Doorkeeper subject to Incorrect Permission Assignment","id":"CVE-2018-1000211","kev_date_added":null,"published":"2018-07-13"},{"cvss_score":6.1,"headline":"Doorkeeper is vulnerable to stored XSS and code execution","id":"CVE-2018-1000088","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":4.2,"headline":"Doorkeeper Improper Authentication vulnerability","id":"CVE-2023-34246","kev_date_added":null,"published":"2023-06-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can hijack user authentication to read OAuth authorization codes via CSRF, requiring victim interaction.","url":"https://insights.sbomify.com/CVE-2014-8144/"}