CVE-2014-8326 phpMyAdmin Implementation XSS Vulnerability on Server Monitor Page
Authenticated users can inject arbitrary scripts via crafted database or table names, potentially compromising other users' sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-8326?
CVE-2014-8326 is a low-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 5 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.5, 4.1.x before 4.1.14.6, and 4.2.x before 4.2.10.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) database name or (2) table name, related to the libraries/DatabaseInterface.class.php code for SQL debug output and the js/server_status_monitor.js code for the server monitor page.
Weakness: CWE-79
Which versions are affected by CVE-2014-8326?
6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.0.0 | 4.0.10.5 |
phpmyadmin/phpmyadmin Packagist | From 4.0.0 | 4.0.10.5 |
phpmyadmin/phpmyadmin Packagist | From 4.1.0 | 4.1.14.6 |
phpmyadmin/phpmyadmin Packagist | From 4.1.0 | 4.1.14.6 |
phpmyadmin/phpmyadmin Packagist | From 4.2.0 | 4.2.10.1 |
phpmyadmin/phpmyadmin Packagist | From 4.2.0 | 4.2.10.1 |
Products include Opensuse Opensuse, Phpmyadmin Phpmyadmin.
How do I fix CVE-2014-8326?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.5, 4.1.14.6 or 4.2.10.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-8326 being exploited?
There is no known exploitation of CVE-2014-8326 in the wild and no public exploit code.
Other vulnerabilities in Opensuse Opensuse
Sources
Also known as DEBIAN-CVE-2014-8326, GHSA-pvr5-84gr-g985, MGASA-2014-0420, UBUNTU-CVE-2014-8326.