{"answers":{"affected":"6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-8326 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.5, 4.1.14.6 or 4.2.10.1.","what":"CVE-2014-8326 is a low-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 5 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-8326 and fix it if it is affected.\n\nWhat it is: CVE-2014-8326 is a low-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 5 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-8326 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.0; fixed in 4.0.10.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.0; fixed in 4.0.10.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.1.0; fixed in 4.1.14.6\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.1.0; fixed in 4.1.14.6\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.2.0; fixed in 4.2.10.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.2.0; fixed in 4.2.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-8326/ (Markdown: https://insights.sbomify.com/CVE-2014-8326/index.md)","id":"CVE-2014-8326","markdown":"https://insights.sbomify.com/CVE-2014-8326/index.md","name":"CVE-2014-8326","record":{"aliases":["DEBIAN-CVE-2014-8326","GHSA-pvr5-84gr-g985","MGASA-2014-0420","UBUNTU-CVE-2014-8326"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Database administration tool","requires_auth":"low_privilege","summary":"Authenticated users can inject arbitrary scripts via crafted database or table names, potentially compromising other users' sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opensuse","vendor":"opensuse"},{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":3.5,"severity":"low","source":"nvd","vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.5, 4.1.x before 4.1.14.6, and 4.2.x before 4.2.10.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) database name or (2) table name, related to the libraries/DatabaseInterface.class.php code for SQL debug output and the js/server_status_monitor.js code for the server monitor page.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin Implementation XSS Vulnerability on Server Monitor Page","id":"CVE-2014-8326","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"opensuse:opensuse","products":["opensuse:opensuse","phpmyadmin:phpmyadmin"],"type":"xss","year":"2014"},"n_packages":6,"n_references":5,"next":{"headline":"fal_sftp extension for TYPO3 uses weak permissions for sFTP driver files and folders","id":"CVE-2014-8327"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.10.5"],"introduced":["4.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-pvr5-84gr-g985"},{"ecosystem":"Packagist","fixed":["4.0.10.5"],"introduced":["4.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-pvr5-84gr-g985"},{"ecosystem":"Packagist","fixed":["4.1.14.6"],"introduced":["4.1.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-pvr5-84gr-g985"},{"ecosystem":"Packagist","fixed":["4.1.14.6"],"introduced":["4.1.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-pvr5-84gr-g985"},{"ecosystem":"Packagist","fixed":["4.2.10.1"],"introduced":["4.2.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-pvr5-84gr-g985"},{"ecosystem":"Packagist","fixed":["4.2.10.1"],"introduced":["4.2.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-pvr5-84gr-g985"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2014-8325"},"products":["n/a"],"published":"2014-11-05","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-5957","kev_date_added":null,"published":"2015-09-28"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0491","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2008-2388","kev_date_added":null,"published":"2008-06-06"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2010-1866","kev_date_added":null,"published":"2010-05-07"},{"cvss_score":9.3,"headline":"Other in n/a","id":"CVE-2015-0492","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2014-0158","kev_date_added":null,"published":"2018-04-10"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2016-4343","kev_date_added":null,"published":"2016-05-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can inject arbitrary scripts via crafted database or table names, potentially compromising other users' sessions.","url":"https://insights.sbomify.com/CVE-2014-8326/"}