# CVE-2014-8326: phpMyAdmin Implementation XSS Vulnerability on Server Monitor Page

> Authenticated users can inject arbitrary scripts via crafted database or table names, potentially compromising other users' sessions.

- **Severity:** Low 3.5 (`AV:N/AC:M/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-8326, GHSA-pvr5-84gr-g985, MGASA-2014-0420, UBUNTU-CVE-2014-8326

## What is CVE-2014-8326?

CVE-2014-8326 is a low-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 5 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.5, 4.1.x before 4.1.14.6, and 4.2.x before 4.2.10.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) database name or (2) table name, related to the libraries/DatabaseInterface.class.php code for SQL debug output and the js/server_status_monitor.js code for the server monitor page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-8326?

6 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0.0 | 4.0.10.5 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0.0 | 4.0.10.5 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.1.0 | 4.1.14.6 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.1.0 | 4.1.14.6 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.2.0 | 4.2.10.1 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.2.0 | 4.2.10.1 |

Products: Opensuse Opensuse, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2014-8326?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 4.0.10.5, 4.1.14.6 or 4.2.10.1.

## Is CVE-2014-8326 being exploited?

There is no known exploitation of CVE-2014-8326 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Opensuse

- [CVE-2015-5957](https://insights.sbomify.com/CVE-2015-5957/): Memory corruption in n/a (critical 10.0)
- [CVE-2015-0491](https://insights.sbomify.com/CVE-2015-0491/): Memory corruption in n/a (critical 10.0)
- [CVE-2008-2388](https://insights.sbomify.com/CVE-2008-2388/): Integer overflow in n/a (critical 10.0)
- [CVE-2010-1866](https://insights.sbomify.com/CVE-2010-1866/): Integer overflow in n/a (critical 9.8)
- [CVE-2015-0492](https://insights.sbomify.com/CVE-2015-0492/): Other in n/a (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-8326 and fix it if it is affected.

What it is: CVE-2014-8326 is a low-severity cross-site scripting vulnerability in Opensuse Opensuse, published on 5 Nov 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-8326 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.0; fixed in 4.0.10.5
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0.0; fixed in 4.0.10.5
- phpmyadmin/phpmyadmin (Packagist): affected from 4.1.0; fixed in 4.1.14.6
- phpmyadmin/phpmyadmin (Packagist): affected from 4.1.0; fixed in 4.1.14.6
- phpmyadmin/phpmyadmin (Packagist): affected from 4.2.0; fixed in 4.2.10.1
- phpmyadmin/phpmyadmin (Packagist): affected from 4.2.0; fixed in 4.2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-8326/ (Markdown: https://insights.sbomify.com/CVE-2014-8326/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-8326
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-8326
- OSV: https://osv.dev/vulnerability/CVE-2014-8326

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-8326/
Summaries are generated and may contain mistakes; the official description above is the record.
