{"answers":{"affected":"2 open source packages ship an affected version, including smarty/smarty. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-8350 in the wild and no public exploit code.","fix":"Upgrade smarty/smarty to 3.1.21 or later.","what":"CVE-2014-8350 is a high-severity code injection vulnerability in n/a, published on 3 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-8350 and fix it if it is affected.\n\nWhat it is: CVE-2014-8350 is a high-severity code injection vulnerability in n/a, published on 3 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-8350 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- smarty/smarty (Packagist): affected all versions; fixed in 3.1.21\n- smarty/smarty (Packagist): affected all versions; fixed in 3.1.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-8350/ (Markdown: https://insights.sbomify.com/CVE-2014-8350/index.md)","id":"CVE-2014-8350","markdown":"https://insights.sbomify.com/CVE-2014-8350/index.md","name":"CVE-2014-8350","record":{"aliases":["DEBIAN-CVE-2014-8350","DLA-452-1","GHSA-2pmx-6mm6-6v72","MGASA-2014-0469"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP template engine","requires_auth":"none","summary":"Remote attackers can bypass secure mode restrictions in the Smarty PHP template engine to execute arbitrary PHP code.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"smarty","vendor":"smarty"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by \"{literal}\u003c{/literal}script language=php\u003e\" in a template.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Smarty arbitrary PHP code execution","id":"CVE-2014-8350","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2014"},"n_packages":2,"n_references":8,"next":{"headline":"SQL injection in n/a","id":"CVE-2014-8351"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.21"],"introduced":["0"],"last_affected":[],"package":"smarty/smarty","purl":null,"source":"GHSA-2pmx-6mm6-6v72"},{"ecosystem":"Packagist","fixed":["3.1.21"],"introduced":["0"],"last_affected":[],"package":"smarty/smarty","purl":"pkg:composer/smarty/smarty","source":"GHSA-2pmx-6mm6-6v72"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-8349"},"products":["n/a"],"published":"2014-11-03","related":[{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-5052","kev_date_added":null,"published":"2011-02-03"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2010-4722","kev_date_added":null,"published":"2011-02-03"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2010-4724","kev_date_added":null,"published":"2011-02-03"},{"cvss_score":10,"headline":"Code injection in n/a","id":"CVE-2010-4725","kev_date_added":null,"published":"2011-02-03"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2010-4726","kev_date_added":null,"published":"2011-02-03"},{"cvss_score":10,"headline":"Code injection in n/a","id":"CVE-2010-4727","kev_date_added":null,"published":"2011-02-03"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2009-1669","kev_date_added":null,"published":"2009-05-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass secure mode restrictions in the Smarty PHP template engine to execute arbitrary PHP code.","url":"https://insights.sbomify.com/CVE-2014-8350/"}