# CVE-2014-8350: Smarty arbitrary PHP code execution

> Remote attackers can bypass secure mode restrictions in the Smarty PHP template engine to execute arbitrary PHP code.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-8350, DLA-452-1, GHSA-2pmx-6mm6-6v72, MGASA-2014-0469

## What is CVE-2014-8350?

CVE-2014-8350 is a high-severity code injection vulnerability in n/a, published on 3 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2014-8350?

2 open source packages ship an affected version, including smarty/smarty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smarty/smarty` | Packagist | All versions | 3.1.21 |
| `smarty/smarty` | Packagist | All versions | 3.1.21 |

Products: Smarty Smarty.

## How do I fix CVE-2014-8350?

Upgrade smarty/smarty to 3.1.21 or later.

## Is CVE-2014-8350 being exploited?

There is no known exploitation of CVE-2014-8350 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2009-5052](https://insights.sbomify.com/CVE-2009-5052/): Other in n/a (critical 10.0)
- [CVE-2010-4722](https://insights.sbomify.com/CVE-2010-4722/): Other in n/a (critical 10.0)
- [CVE-2010-4724](https://insights.sbomify.com/CVE-2010-4724/): Other in n/a (critical 10.0)
- [CVE-2010-4725](https://insights.sbomify.com/CVE-2010-4725/): Code injection in n/a (critical 10.0)
- [CVE-2010-4726](https://insights.sbomify.com/CVE-2010-4726/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-8350 and fix it if it is affected.

What it is: CVE-2014-8350 is a high-severity code injection vulnerability in n/a, published on 3 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-8350 in the wild and no public exploit code.

Affected packages and fixed versions:
- smarty/smarty (Packagist): affected all versions; fixed in 3.1.21
- smarty/smarty (Packagist): affected all versions; fixed in 3.1.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-8350/ (Markdown: https://insights.sbomify.com/CVE-2014-8350/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-8350
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-8350
- OSV: https://osv.dev/vulnerability/CVE-2014-8350

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-8350/
Summaries are generated and may contain mistakes; the official description above is the record.
