# CVE-2014-8682: SQL Injection in Gogs

> Remote attackers can execute arbitrary SQL commands via search parameters in Gogs, potentially reading or modifying database contents.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-g6xv-8q23-w2q3, GO-2022-0831

## What is CVE-2014-8682?

CVE-2014-8682 is a high-severity SQL injection vulnerability in n/a, published on 21 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple SQL injection vulnerabilities in Gogs (aka Go Git Service) 0.3.1-9 through 0.5.x before 0.5.6.1105 Beta allow remote attackers to execute arbitrary SQL commands via the q parameter to (1) api/v1/repos/search, which is not properly handled in models/repo.go, or (2) api/v1/users/search, which is not properly handled in models/user.go.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2014-8682?

3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | From 0.3.1 | 0.5.8 |
| `gogs.io/gogs` | Go | From 0.3.1 | 0.5.8 |
| `gogs.io/gogs` | Go | From 0.3.1 | 0.5.8 |

Products: Gogits Gogs.

## How do I fix CVE-2014-8682?

Upgrade gogs.io/gogs to 0.5.8 or later.

## Is CVE-2014-8682 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-8682 exists.

Public exploit code:

- Gogs - 'users'/'repos' '?q' SQL Injection (exploitdb)
- CVE-2014-8682 (github_poc): https://github.com/nihal1306/gogs
- Gogs (Go Git Service) - SQL Injection (nuclei): http/cves/2014/CVE-2014-8682.yaml

## Other vulnerabilities in n/a

- [CVE-2014-8681](https://insights.sbomify.com/CVE-2014-8681/): SQL Injection in gogs.io/gogs (high 7.5)
- [CVE-2014-8683](https://insights.sbomify.com/CVE-2014-8683/): Cross-site Scripting in Gogs (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-8682 and fix it if it is affected.

What it is: CVE-2014-8682 is a high-severity SQL injection vulnerability in n/a, published on 21 Nov 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-8682 exists.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected from 0.3.1; fixed in 0.5.8
- gogs.io/gogs (Go): affected from 0.3.1; fixed in 0.5.8
- gogs.io/gogs (Go): affected from 0.3.1; fixed in 0.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-8682/ (Markdown: https://insights.sbomify.com/CVE-2014-8682/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-8682
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-8682
- OSV: https://osv.dev/vulnerability/CVE-2014-8682

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-8682/
Summaries are generated and may contain mistakes; the official description above is the record.
