{"answers":{"affected":"4 open source packages ship an affected version, including codeigniter/framework and kohana/core. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-8684 exists.","fix":"Upgrade codeigniter/framework to 3.0.0 or later.","what":"CVE-2014-8684 is a critical unsafe deserialization vulnerability in n/a, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-8684 and fix it if it is affected.\n\nWhat it is: CVE-2014-8684 is a critical unsafe deserialization vulnerability in n/a, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-8684 exists.\n\nAffected packages and fixed versions:\n- codeigniter/framework (Packagist): affected all versions; fixed in 3.0.0\n- codeigniter/framework (Packagist): affected all versions; fixed in 3.0.0\n- kohana/core (Packagist): affected all versions; fixed in 3.3.3\n- kohana/core (Packagist): affected all versions; fixed in 3.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-8684/ (Markdown: https://insights.sbomify.com/CVE-2014-8684/index.md)","id":"CVE-2014-8684","markdown":"https://insights.sbomify.com/CVE-2014-8684/index.md","name":"CVE-2014-8684","record":{"aliases":["GHSA-w9ph-q4h9-rwq6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"Remote attackers can spoof session cookies to trigger PHP object injection and execute arbitrary code due to insecure hash comparison.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"codeigniter","vendor":"codeigniter"},{"product":"kohana","vendor":"kohanaframework"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-310","name":null}],"description":"CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard string comparison operators to compare cryptographic hashes.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2015-03-01","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2015-03-01","kind":"metasploit","ref":"exploit/linux/http/seagate_nas_php_exec_noauth","stars":null,"title":"Seagate Business NAS Unauthenticated Remote Command Execution"},{"date":"2015-03-04","kind":"exploitdb","ref":"36264","stars":null,"title":"Seagate Business NAS - Remote Command Execution (Metasploit)"}],"tier":"weaponised"},"has_fix":true,"headline":"CodeIgniter and Kohana vulnerable to PHP Object Injection","id":"CVE-2014-8684","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2014"},"n_packages":4,"n_references":4,"next":{"headline":"Weak cryptography in n/a","id":"CVE-2014-8686"},"packages":[{"ecosystem":"Packagist","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"codeigniter/framework","purl":null,"source":"GHSA-w9ph-q4h9-rwq6"},{"ecosystem":"Packagist","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"codeigniter/framework","purl":"pkg:composer/codeigniter/framework","source":"GHSA-w9ph-q4h9-rwq6"},{"ecosystem":"Packagist","fixed":["3.3.3"],"introduced":["0"],"last_affected":[],"package":"kohana/core","purl":null,"source":"GHSA-w9ph-q4h9-rwq6"},{"ecosystem":"Packagist","fixed":["3.3.3"],"introduced":["0"],"last_affected":[],"package":"kohana/core","purl":"pkg:composer/kohana/core","source":"GHSA-w9ph-q4h9-rwq6"}],"prev":{"headline":"Cross-site Scripting in Gogs","id":"CVE-2014-8683"},"products":["n/a"],"published":"2017-09-19","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can spoof session cookies to trigger PHP object injection and execute arbitrary code due to insecure hash comparison.","url":"https://insights.sbomify.com/CVE-2014-8684/"}