# CVE-2014-8684: CodeIgniter and Kohana vulnerable to PHP Object Injection

> Remote attackers can spoof session cookies to trigger PHP object injection and execute arbitrary code due to insecure hash comparison.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-w9ph-q4h9-rwq6

## What is CVE-2014-8684?

CVE-2014-8684 is a critical unsafe deserialization vulnerability in n/a, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it easier for remote attackers to spoof session cookies and consequently conduct PHP object injection attacks by leveraging use of standard string comparison operators to compare cryptographic hashes.

Weakness: CWE-310

## Which versions are affected by CVE-2014-8684?

4 open source packages ship an affected version, including codeigniter/framework and kohana/core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter/framework` | Packagist | All versions | 3.0.0 |
| `codeigniter/framework` | Packagist | All versions | 3.0.0 |
| `kohana/core` | Packagist | All versions | 3.3.3 |
| `kohana/core` | Packagist | All versions | 3.3.3 |

Products: Codeigniter Codeigniter, Kohanaframework Kohana.

## How do I fix CVE-2014-8684?

Upgrade codeigniter/framework to 3.0.0 or later.

## Is CVE-2014-8684 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-8684 exists.

Public exploit code:

- Seagate Business NAS Unauthenticated Remote Command Execution (metasploit)
- Seagate Business NAS - Remote Command Execution (Metasploit) (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-8684 and fix it if it is affected.

What it is: CVE-2014-8684 is a critical unsafe deserialization vulnerability in n/a, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-8684 exists.

Affected packages and fixed versions:
- codeigniter/framework (Packagist): affected all versions; fixed in 3.0.0
- codeigniter/framework (Packagist): affected all versions; fixed in 3.0.0
- kohana/core (Packagist): affected all versions; fixed in 3.3.3
- kohana/core (Packagist): affected all versions; fixed in 3.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-8684/ (Markdown: https://insights.sbomify.com/CVE-2014-8684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-8684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-8684
- OSV: https://osv.dev/vulnerability/CVE-2014-8684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-8684/
Summaries are generated and may contain mistakes; the official description above is the record.
