# CVE-2014-8991: pip lack of randomness in build directory

> Local attackers can prevent package installation by creating specific temporary files, affecting Python developers using pip.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-8991, GHSA-53mr-44pp-crf4, MGASA-2015-0023, PYSEC-2014-11, UBUNTU-CVE-2014-8991

## What is CVE-2014-8991?

CVE-2014-8991 is a low-severity denial of service vulnerability in Oracle Solaris, published on 24 Nov 2014. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pip 1.3 through 1.5.6 allows local users to cause a denial of service (prevention of package installation) by creating a /tmp/pip-build-* file for another user.

## Which versions are affected by CVE-2014-8991?

3 open source packages ship an affected version, including pip. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pip` | PyPI | From 1.3 | 6.0 |
| `pip` | PyPI | From 1.3 | 6.0 |
| `pip` | PyPI | From 1.3 | 6.0 |

Products: Oracle Solaris, Pypa Pip.

## How do I fix CVE-2014-8991?

Upgrade pip to 6.0 or later.

## Is CVE-2014-8991 being exploited?

There is no known exploitation of CVE-2014-8991 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Solaris

- [CVE-2020-14871](https://insights.sbomify.com/CVE-2020-14871/): Oracle Solaris and Zettabyte File System (ZFS) Unspecified (critical 10.0, exploited in the wild)
- [CVE-2019-3010](https://insights.sbomify.com/CVE-2019-3010/): Oracle Solaris Privilege Escalation (high 8.8, exploited in the wild)
- [CVE-2026-46978](https://insights.sbomify.com/CVE-2026-46978/): Missing authorization in Oracle Solaris (critical 10.0)
- [CVE-2017-3623](https://insights.sbomify.com/CVE-2017-3623/): Other in Solaris Operating System (critical 10.0)
- [CVE-2014-0397](https://insights.sbomify.com/CVE-2014-0397/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-8991 and fix it if it is affected.

What it is: CVE-2014-8991 is a low-severity denial of service vulnerability in Oracle Solaris, published on 24 Nov 2014. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-8991 in the wild and no public exploit code.

Affected packages and fixed versions:
- pip (PyPI): affected from 1.3; fixed in 6.0
- pip (PyPI): affected from 1.3; fixed in 6.0
- pip (PyPI): affected from 1.3; fixed in 6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-8991/ (Markdown: https://insights.sbomify.com/CVE-2014-8991/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-8991
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-8991
- OSV: https://osv.dev/vulnerability/CVE-2014-8991

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-8991/
Summaries are generated and may contain mistakes; the official description above is the record.
