CVE-2014-9059 Moodle does not provide charset information in HTTP headers
Remote attackers can execute cross-site scripting attacks via UTF-7 characters in AJAX interactions due to missing charset headers in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-9059?
CVE-2014-9059 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 24 Nov 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
lib/setup.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide charset information in HTTP headers, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via UTF-7 characters during interaction with AJAX scripts.
Weakness: CWE-79
Which versions are affected by CVE-2014-9059?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.5.9 |
moodle/moodle Packagist | All versions | 2.5.9 |
moodle/moodle Packagist | From 2.6.0 | 2.6.6 |
moodle/moodle Packagist | From 2.6.0 | 2.6.6 |
moodle/moodle Packagist | From 2.7.0 | 2.7.3 |
moodle/moodle Packagist | From 2.7.0 | 2.7.3 |
Products include Moodle Moodle.
How do I fix CVE-2014-9059?
Upgrade moodle/moodle to a fixed version for your release line: 2.5.9, 2.6.6 or 2.7.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-9059 being exploited?
There is no known exploitation of CVE-2014-9059 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-crcq-pw8h-9xwf.