# CVE-2014-9279: Information disclosure in n/a

> Remote attackers with admin access can leak database credentials by manipulating the hostname parameter in the unattended upgrade script.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Dec 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-735c-hjfp-pf6m

## What is CVE-2014-9279?

CVE-2014-9279 is a medium-severity vulnerability in Mantisbt Mantisbt, published on 8 Dec 2014. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The print_test_result function in admin/upgrade_unattended.php in MantisBT 1.1.0a3 through 1.2.x before 1.2.18 allows remote attackers to obtain database credentials via a URL in the hostname parameter and reading the parameters in the response sent to the URL.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-9279?

It affects 1 product.


Products: Mantisbt Mantisbt.

## How do I fix CVE-2014-9279?

No fix has been published for CVE-2014-9279 yet. Limit exposure of the affected software until one is available.

## Is CVE-2014-9279 being exploited?

There is no known exploitation of CVE-2014-9279 in the wild and no public exploit code.

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2026-30849](https://insights.sbomify.com/CVE-2026-30849/): MantisBT SOAP API has an authentication bypass vulnerability on MySQL (critical 9.3)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2017-7615](https://insights.sbomify.com/CVE-2017-7615/): MantisBT allows arbitrary password reset (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9279 and fix it if it is affected.

What it is: CVE-2014-9279 is a medium-severity vulnerability in Mantisbt Mantisbt, published on 8 Dec 2014. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-9279 in the wild and no public exploit code.

Affected product: Mantisbt Mantisbt. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9279/ (Markdown: https://insights.sbomify.com/CVE-2014-9279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9279
- OSV: https://osv.dev/vulnerability/CVE-2014-9279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9279/
Summaries are generated and may contain mistakes; the official description above is the record.
