# CVE-2014-9357: Arbitrary Code Execution

> Remote attackers can execute arbitrary code with root privileges by providing a crafted LZMA archive in a Docker image or build.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Dec 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-9357, GHSA-997c-fj8j-rq5h, GO-2022-0640

## What is CVE-2014-9357?

CVE-2014-9357 is a critical code injection vulnerability in n/a, published on 16 Dec 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Docker 1.3.2 allows remote attackers to execute arbitrary code with root privileges via a crafted (1) image or (2) build in a Dockerfile in an LZMA (.xz) archive, related to the chroot for archive extraction.

Weakness: CWE-264

## Which versions are affected by CVE-2014-9357?

3 open source packages ship an affected version, including github.com/docker/docker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/docker/docker` | Go | All versions | 1.3.3 |
| `github.com/docker/docker` | Go | All versions | 1.3.3 |
| `github.com/docker/docker` | Go | All versions | 1.3.3 |

Products: Docker Docker.

## How do I fix CVE-2014-9357?

Upgrade github.com/docker/docker to 1.3.3 or later.

## Is CVE-2014-9357 being exploited?

There is no known exploitation of CVE-2014-9357 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-14298](https://insights.sbomify.com/CVE-2020-14298/): Privilege escalation in Docker (high 8.8)
- [CVE-2020-14300](https://insights.sbomify.com/CVE-2020-14300/): Privilege escalation in Docker (high 8.8)
- [CVE-2018-15514](https://insights.sbomify.com/CVE-2018-15514/): Deserialization in n/a (high 8.8)
- [CVE-2014-9356](https://insights.sbomify.com/CVE-2014-9356/): Path Traversal in Docker (high 8.6)
- [CVE-2019-13139](https://insights.sbomify.com/CVE-2019-13139/): Command injection in n/a (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9357 and fix it if it is affected.

What it is: CVE-2014-9357 is a critical code injection vulnerability in n/a, published on 16 Dec 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-9357 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/docker/docker (Go): affected all versions; fixed in 1.3.3
- github.com/docker/docker (Go): affected all versions; fixed in 1.3.3
- github.com/docker/docker (Go): affected all versions; fixed in 1.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9357/ (Markdown: https://insights.sbomify.com/CVE-2014-9357/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9357
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9357
- OSV: https://osv.dev/vulnerability/CVE-2014-9357

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9357/
Summaries are generated and may contain mistakes; the official description above is the record.
