# CVE-2014-9462: Mercurial vulnerable to arbitrary command execution via a crafted repository name in a clone command

> Remote attackers can execute arbitrary commands on Mercurial clients by tricking users into cloning a repository with a crafted name.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-9462, DSA-3257-1, GHSA-3pmw-h7j4-rf54, MGASA-2015-0129, PYSEC-2015-14, SUSE-SU-2015:0817-1, SUSE-SU-2015:0836-1, UBUNTU-CVE-2014-9462

## What is CVE-2014-9462?

CVE-2014-9462 is a high-severity command injection vulnerability in Opensuse Opensuse, published on 31 Mar 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-9462?

3 open source packages ship an affected version, including mercurial. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercurial` | PyPI | All versions | 3.2.4 |
| `mercurial` | PyPI | All versions | 3.2.4 |
| `mercurial` | PyPI | All versions | 3.2.4 |
| `mercurial` | SUSE:Linux Enterprise Software Development Kit 12 | All versions | 2.8.2-3.1 |

Products: Mercurial Mercurial, Opensuse Opensuse.

## How do I fix CVE-2014-9462?

Upgrade mercurial to 3.2.4 or later.

## Is CVE-2014-9462 being exploited?

There is no known exploitation of CVE-2014-9462 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Opensuse

- [CVE-2018-13347](https://insights.sbomify.com/CVE-2018-13347/): Mercurial mishandles integer addition and subtraction (critical 9.8)
- [CVE-2018-17983](https://insights.sbomify.com/CVE-2018-17983/): Mercurial Out-of-bounds Read vulnerability (critical 9.1)
- [CVE-2018-13346](https://insights.sbomify.com/CVE-2018-13346/): Mercurial Improper Input Validation vulnerability (high 7.5)
- [CVE-2018-13348](https://insights.sbomify.com/CVE-2018-13348/): Mercurial Improper Input Validation vulnerability (high 7.5)
- [CVE-2008-2942](https://insights.sbomify.com/CVE-2008-2942/): Mercurial Directory traversal vulnerability (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9462 and fix it if it is affected.

What it is: CVE-2014-9462 is a high-severity command injection vulnerability in Opensuse Opensuse, published on 31 Mar 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-9462 in the wild and no public exploit code.

Affected packages and fixed versions:
- mercurial (PyPI): affected all versions; fixed in 3.2.4
- mercurial (PyPI): affected all versions; fixed in 3.2.4
- mercurial (PyPI): affected all versions; fixed in 3.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9462/ (Markdown: https://insights.sbomify.com/CVE-2014-9462/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9462
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9462
- OSV: https://osv.dev/vulnerability/CVE-2014-9462

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9462/
Summaries are generated and may contain mistakes; the official description above is the record.
