{"answers":{"affected":"4 open source packages ship an affected version, including gollum and gollum-lib. It affects 3 products.","exploited":"There is no known exploitation of CVE-2014-9489 in the wild and no public exploit code.","fix":"Upgrade gollum to 3.1.1 or later.","what":"CVE-2014-9489 is a high-severity command injection vulnerability in n/a, published on 17 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-9489 and fix it if it is affected.\n\nWhat it is: CVE-2014-9489 is a high-severity command injection vulnerability in n/a, published on 17 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-9489 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gollum (RubyGems): affected all versions; fixed in 3.1.1\n- gollum (RubyGems): affected all versions; fixed in 3.1.1\n- gollum-lib (RubyGems): affected all versions; fixed in 4.0.1\n- gollum-lib (RubyGems): affected all versions; fixed in 4.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-9489/ (Markdown: https://insights.sbomify.com/CVE-2014-9489/index.md)","id":"CVE-2014-9489","markdown":"https://insights.sbomify.com/CVE-2014-9489/index.md","name":"CVE-2014-9489","record":{"aliases":["GHSA-q97v-764g-r2rp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby wiki library","requires_auth":"low_privilege","summary":"Remote authenticated users can execute arbitrary code via command injection in gollum wiki libraries when specific strings are present.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gollum","vendor":"gollum_project"},{"product":"gollum-lib","vendor":"gollum_project"},{"product":"grit_adapter","vendor":"gollum_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string \"master\" is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"gollum and gollum-lib allow remote authenticated users to execute arbitrary code","id":"CVE-2014-9489","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2014"},"n_packages":4,"n_references":4,"next":{"headline":"sentry-raven allows remote attackers to cause a denial of service via a large exponent value in a scientific number","id":"CVE-2014-9490"},"packages":[{"ecosystem":"RubyGems","fixed":["3.1.1"],"introduced":["0"],"last_affected":[],"package":"gollum","purl":null,"source":"GHSA-q97v-764g-r2rp"},{"ecosystem":"RubyGems","fixed":["3.1.1"],"introduced":["0"],"last_affected":[],"package":"gollum","purl":"pkg:gem/gollum","source":"GHSA-q97v-764g-r2rp"},{"ecosystem":"RubyGems","fixed":["4.0.1"],"introduced":["0"],"last_affected":[],"package":"gollum-lib","purl":null,"source":"GHSA-q97v-764g-r2rp"},{"ecosystem":"RubyGems","fixed":["4.0.1"],"introduced":["0"],"last_affected":[],"package":"gollum-lib","purl":"pkg:gem/gollum-lib","source":"GHSA-q97v-764g-r2rp"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2014-9488"},"products":["n/a"],"published":"2017-10-17","related":[{"cvss_score":6.1,"headline":"Gollum Cross-site Scripting vulnerability via filename parameter to New Page dialog","id":"CVE-2020-35305","kev_date_added":null,"published":"2022-07-15"},{"cvss_score":4.3,"headline":"Gollum Exposure of Sensitive Information","id":"CVE-2015-7314","kev_date_added":null,"published":"2015-10-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote authenticated users can execute arbitrary code via command injection in gollum wiki libraries when specific strings are present.","url":"https://insights.sbomify.com/CVE-2014-9489/"}