# CVE-2014-9489: gollum and gollum-lib allow remote authenticated users to execute arbitrary code

> Remote authenticated users can execute arbitrary code via command injection in gollum wiki libraries when specific strings are present.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-q97v-764g-r2rp

## What is CVE-2014-9489?

CVE-2014-9489 is a high-severity command injection vulnerability in n/a, published on 17 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The gollum-grit_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the string "master" is in any of the wiki documents, allows remote authenticated users to execute arbitrary code via the -O or --open-files-in-pager flags.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2014-9489?

4 open source packages ship an affected version, including gollum and gollum-lib. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gollum` | RubyGems | All versions | 3.1.1 |
| `gollum` | RubyGems | All versions | 3.1.1 |
| `gollum-lib` | RubyGems | All versions | 4.0.1 |
| `gollum-lib` | RubyGems | All versions | 4.0.1 |

Products: Gollum Project Gollum, Gollum Project Gollum-Lib, Gollum Project Grit Adapter.

## How do I fix CVE-2014-9489?

Upgrade gollum to 3.1.1 or later.

## Is CVE-2014-9489 being exploited?

There is no known exploitation of CVE-2014-9489 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-35305](https://insights.sbomify.com/CVE-2020-35305/): Gollum Cross-site Scripting vulnerability via filename parameter to New Page dialog (medium 6.1)
- [CVE-2015-7314](https://insights.sbomify.com/CVE-2015-7314/): Gollum Exposure of Sensitive Information (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9489 and fix it if it is affected.

What it is: CVE-2014-9489 is a high-severity command injection vulnerability in n/a, published on 17 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-9489 in the wild and no public exploit code.

Affected packages and fixed versions:
- gollum (RubyGems): affected all versions; fixed in 3.1.1
- gollum (RubyGems): affected all versions; fixed in 3.1.1
- gollum-lib (RubyGems): affected all versions; fixed in 4.0.1
- gollum-lib (RubyGems): affected all versions; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9489/ (Markdown: https://insights.sbomify.com/CVE-2014-9489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9489
- OSV: https://osv.dev/vulnerability/CVE-2014-9489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9489/
Summaries are generated and may contain mistakes; the official description above is the record.
