{"answers":{"affected":"2 open source packages ship an affected version, including sentry-raven. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-9490 in the wild and no public exploit code.","fix":"Upgrade sentry-raven to 0.12.2 or later.","what":"CVE-2014-9490 is a medium-severity denial of service vulnerability in n/a, published on 20 Jan 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-9490 and fix it if it is affected.\n\nWhat it is: CVE-2014-9490 is a medium-severity denial of service vulnerability in n/a, published on 20 Jan 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-9490 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentry-raven (RubyGems): affected all versions; fixed in 0.12.2\n- sentry-raven (RubyGems): affected all versions; fixed in 0.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-9490/ (Markdown: https://insights.sbomify.com/CVE-2014-9490/index.md)","id":"CVE-2014-9490","markdown":"https://insights.sbomify.com/CVE-2014-9490/index.md","name":"CVE-2014-9490","record":{"aliases":["GHSA-c9c5-9fpr-m882"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby JSON library","requires_auth":"none","summary":"Remote attackers can cause denial of service in the raven-ruby gem by sending a large exponent value in a scientific number.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"raven-ruby","vendor":"getsentry"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"The numtok function in lib/raven/okjson.rb in the raven-ruby gem before 0.12.2 for Ruby allows remote attackers to cause a denial of service via a large exponent value in a scientific number.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"sentry-raven allows remote attackers to cause a denial of service via a large exponent value in a scientific number","id":"CVE-2014-9490","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2014"},"n_packages":2,"n_references":4,"next":{"headline":"Null dereference in n/a","id":"CVE-2014-9491"},"packages":[{"ecosystem":"RubyGems","fixed":["0.12.2"],"introduced":["0"],"last_affected":[],"package":"sentry-raven","purl":null,"source":"GHSA-c9c5-9fpr-m882"},{"ecosystem":"RubyGems","fixed":["0.12.2"],"introduced":["0"],"last_affected":[],"package":"sentry-raven","purl":"pkg:gem/sentry-raven","source":"GHSA-c9c5-9fpr-m882"}],"prev":{"headline":"gollum and gollum-lib allow remote authenticated users to execute arbitrary code","id":"CVE-2014-9489"},"products":["n/a"],"published":"2015-01-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service in the raven-ruby gem by sending a large exponent value in a scientific number.","url":"https://insights.sbomify.com/CVE-2014-9490/"}