# CVE-2014-9509: Typo3 Vulnerable to Cache Poisoning

> Remote attackers can cause resource consumption and page reloads via cache poisoning in TYPO3 when specific anchor prefixing settings are enabled.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2015
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-5479-gqqr-f9gj

## What is CVE-2014-9509?

CVE-2014-9509 is a high-severity denial of service vulnerability in Typo3 Typo3, published on 4 Jan 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The frontend rendering component in TYPO3 4.5.x before 4.5.39, 4.6.x through 6.2.x before 6.2.9, and 7.x before 7.0.2, when config.prefixLocalAnchors is set to all or cached, allows remote attackers to have an unspecified impact (possibly resource consumption) via a "Cache Poisoning" attack using a URL with arbitrary arguments, which triggers a reload of the page.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-9509?

14 open source packages ship an affected version, including typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 4.5.0 | 4.5.39 |
| `typo3/cms` | Packagist | From 4.5.0 | 4.5.39 |
| `typo3/cms` | Packagist | From 4.6.0 | 4.6.19 |
| `typo3/cms` | Packagist | From 4.6.0 | 4.6.19 |
| `typo3/cms` | Packagist | From 4.7.0 | 4.7.21 |
| `typo3/cms` | Packagist | From 4.7.0 | 4.7.21 |
| `typo3/cms` | Packagist | From 6.0.0 | 6.0.15 |
| `typo3/cms` | Packagist | From 6.0.0 | 6.0.15 |
| `typo3/cms` | Packagist | From 6.1.0 | 6.1.13 |
| `typo3/cms` | Packagist | From 6.1.0 | 6.1.13 |
| `typo3/cms` | Packagist | From 6.2.0 | 6.2.9 |
| `typo3/cms` | Packagist | From 6.2.0 | 6.2.9 |
| `typo3/cms` | Packagist | From 7.0.0 | 7.0.2 |
| `typo3/cms` | Packagist | From 7.0.0 | 7.0.2 |

Products: Typo3 Typo3.

## How do I fix CVE-2014-9509?

Upgrade typo3/cms to a fixed version for your release line: 4.5.39, 4.6.19, 4.7.21 or 6.0.15.

## Is CVE-2014-9509 being exploited?

There is no known exploitation of CVE-2014-9509 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9509 and fix it if it is affected.

What it is: CVE-2014-9509 is a high-severity denial of service vulnerability in Typo3 Typo3, published on 4 Jan 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-9509 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.39
- typo3/cms (Packagist): affected from 4.5.0; fixed in 4.5.39
- typo3/cms (Packagist): affected from 4.6.0; fixed in 4.6.19
- typo3/cms (Packagist): affected from 4.6.0; fixed in 4.6.19
- typo3/cms (Packagist): affected from 4.7.0; fixed in 4.7.21
- typo3/cms (Packagist): affected from 4.7.0; fixed in 4.7.21
- typo3/cms (Packagist): affected from 6.0.0; fixed in 6.0.15
- typo3/cms (Packagist): affected from 6.0.0; fixed in 6.0.15
- typo3/cms (Packagist): affected from 6.1.0; fixed in 6.1.13
- typo3/cms (Packagist): affected from 6.1.0; fixed in 6.1.13
- typo3/cms (Packagist): affected from 6.2.0; fixed in 6.2.9
- typo3/cms (Packagist): affected from 6.2.0; fixed in 6.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9509/ (Markdown: https://insights.sbomify.com/CVE-2014-9509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9509
- OSV: https://osv.dev/vulnerability/CVE-2014-9509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9509/
Summaries are generated and may contain mistakes; the official description above is the record.
