{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.poi:poi. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-9527 in the wild and no public exploit code.","fix":"Upgrade org.apache.poi:poi to 3.11 or later.","what":"CVE-2014-9527 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-9527 and fix it if it is affected.\n\nWhat it is: CVE-2014-9527 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 6 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-9527 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.poi:poi (Maven): affected all versions; fixed in 3.11\n- org.apache.poi:poi (Maven): affected all versions; fixed in 3.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-9527/ (Markdown: https://insights.sbomify.com/CVE-2014-9527/index.md)","id":"CVE-2014-9527","markdown":"https://insights.sbomify.com/CVE-2014-9527/index.md","name":"CVE-2014-9527","record":{"aliases":["DEBIAN-CVE-2014-9527","GHSA-x9mm-6gpf-f749","MGASA-2015-0087","UBUNTU-CVE-2014-9527"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java Office library","requires_auth":"none","summary":"Remote attackers can cause a denial of service via infinite loop and deadlock by tricking users into opening a crafted PPT file with Apache POI.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"poi","vendor":"apache"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"HSLFSlideShow in Apache POI before 3.11 allows remote attackers to cause a denial of service (infinite loop and deadlock) via a crafted PPT file.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Loop with Unreachable Exit Condition in Apache POI","id":"CVE-2014-9527","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2014"},"n_packages":2,"n_references":7,"next":{"headline":"SQL injection in n/a","id":"CVE-2014-9528"},"packages":[{"ecosystem":"Maven","fixed":["3.11"],"introduced":["0"],"last_affected":[],"package":"org.apache.poi:poi","purl":null,"source":"GHSA-x9mm-6gpf-f749"},{"ecosystem":"Maven","fixed":["3.11"],"introduced":["0"],"last_affected":[],"package":"org.apache.poi:poi","purl":"pkg:maven/org.apache.poi/poi","source":"GHSA-x9mm-6gpf-f749"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-9526"},"products":["n/a"],"published":"2015-01-06","related":[{"cvss_score":7.5,"headline":"Denial of Service in Apache POI","id":"CVE-2017-12626","kev_date_added":null,"published":"2018-01-29"},{"cvss_score":5.5,"headline":"A carefully crafted TNEF file can cause an out of memory exception","id":"CVE-2022-26336","kev_date_added":null,"published":"2022-03-04"},{"cvss_score":5.5,"headline":"Improper Restriction of XML External Entity Reference in Apache POI","id":"CVE-2019-12415","kev_date_added":null,"published":"2019-10-23"},{"cvss_score":5.5,"headline":"Improper Restriction of Recursive Entity References in DTDs in Apache POI","id":"CVE-2017-5644","kev_date_added":null,"published":"2017-03-24"},{"cvss_score":5.5,"headline":"Apache POI's XLSX2CSV Example XML External Entity (XXE) Vulnerability","id":"CVE-2016-5000","kev_date_added":null,"published":"2016-08-05"},{"cvss_score":5.3,"headline":"Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing","id":"CVE-2025-31672","kev_date_added":null,"published":"2025-04-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via infinite loop and deadlock by tricking users into opening a crafted PPT file with Apache POI.","url":"https://insights.sbomify.com/CVE-2014-9527/"}