# CVE-2014-9568: Information disclosure in n/a

> Local attackers can retrieve sensitive RabbitMQ Erlang cookies from node facts, potentially compromising message queue security.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-h3gh-978r-747w

## What is CVE-2014-9568?

CVE-2014-9568 is a low-severity vulnerability in n/a, published on 3 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

puppetlabs-rabbitmq 3.0 through 4.1 stores the RabbitMQ Erlang cookie value in the facts of a node, which allows local users to obtain sensitive information as demonstrated by using Facter.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-9568?

1 open source package ship an affected version, including puppetlabs-rabbitmq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puppetlabs-rabbitmq` | Hex | From 3.0 | 5.0 |

Products: Voxpupuli Rabbitmq.

## How do I fix CVE-2014-9568?

Upgrade puppetlabs-rabbitmq to 5.0 or later.

## Is CVE-2014-9568 being exploited?

There is no known exploitation of CVE-2014-9568 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9568 and fix it if it is affected.

What it is: CVE-2014-9568 is a low-severity vulnerability in n/a, published on 3 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-9568 in the wild and no public exploit code.

Affected packages and fixed versions:
- puppetlabs-rabbitmq (Hex): affected from 3.0; fixed in 5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9568/ (Markdown: https://insights.sbomify.com/CVE-2014-9568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9568
- OSV: https://osv.dev/vulnerability/CVE-2014-9568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9568/
Summaries are generated and may contain mistakes; the official description above is the record.
