# CVE-2014-9601: Pillow denial of service via PNG bomb

> Remote attackers can cause a denial of service in Pillow by submitting a malicious PNG image with a large decompressed text chunk.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jan 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-9601, GHSA-h5rf-vgqx-wjv2, MGASA-2015-0039, PYSEC-2015-16, UBUNTU-CVE-2014-9601, USN-3090-2

## What is CVE-2014-9601?

CVE-2014-9601 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 16 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pillow before 2.7.0 allows remote attackers to cause a denial of service via a compressed text chunk in a PNG image that has a large size when it is decompressed.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-9601?

3 open source packages ship an affected version, including pillow. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | PyPI | All versions | 2.7.0 |
| `pillow` | PyPI | All versions | 2.7.0 |
| `pillow` | PyPI | All versions | 2.7.0 |

Products: Fedoraproject Fedora, Opensuse Opensuse, Oracle Solaris, Python Pillow.

## How do I fix CVE-2014-9601?

Upgrade pillow to 2.7.0 or later.

## Is CVE-2014-9601 being exploited?

There is no known exploitation of CVE-2014-9601 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9601 and fix it if it is affected.

What it is: CVE-2014-9601 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 16 Jan 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-9601 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (PyPI): affected all versions; fixed in 2.7.0
- pillow (PyPI): affected all versions; fixed in 2.7.0
- pillow (PyPI): affected all versions; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9601/ (Markdown: https://insights.sbomify.com/CVE-2014-9601/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9601
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9601
- OSV: https://osv.dev/vulnerability/CVE-2014-9601

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9601/
Summaries are generated and may contain mistakes; the official description above is the record.
