# CVE-2014-9684: OpenStack Glance Denial of service by creating a large number of images

> Authenticated users can cause disk consumption denial of service by creating and deleting images via the task v2 API.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-h737-q6g6-8wr6, PYSEC-2015-37, SUSE-SU-2015:1515-1

## What is CVE-2014-9684?

CVE-2014-9684 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenStack Image Registry and Delivery Service (Glance) 2014.2 through 2014.2.2 does not properly remove images, which allows remote authenticated users to cause a denial of service (disk consumption) by creating a large number of images using the task v2 API and then deleting them before the uploads finish, a different vulnerability than CVE-2015-1881.

Weakness: CWE-399

## Which versions are affected by CVE-2014-9684?

3 open source packages ship an affected version, including glance. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glance` | PyPI | All versions | 11.0.0a0 |
| `glance` | PyPI | All versions | 11.0.0a0 |
| `glance` | PyPI | All versions | 11.0.0a0 |
| `openstack-ceilometer` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev18-9.7 |
| `openstack-ceilometer-doc` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev18-9.11 |
| `openstack-cinder` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev19-9.7 |
| `openstack-cinder-doc` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev19-9.12 |
| `openstack-glance` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev5-9.5 |
| `openstack-glance-doc` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev5-9.7 |
| `openstack-heat` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev13-9.6 |
| `openstack-heat-doc` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev13-9.8 |
| `openstack-keystone` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev5-11.8 |
| `openstack-keystone-doc` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev5-11.12 |
| `openstack-sahara` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev3-9.5 |
| `openstack-sahara-doc` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4.dev3-9.5 |
| `openstack-suse` | SUSE:OpenStack Cloud 5 | All versions | 2014.2-9.2 |
| `python-oslo.i18n` | SUSE:OpenStack Cloud 5 | All versions | 1.3.1-9.6 |
| `python-oslo.utils` | SUSE:OpenStack Cloud 5 | All versions | 1.4.0-14.2 |
| `python-oslotest` | SUSE:OpenStack Cloud 5 | All versions | 1.2.0-2.5 |
| `python-six` | SUSE:OpenStack Cloud 5 | All versions | 1.9.0-9.2 |

Products: Openstack Image Registry and Delivery Service \(Glance\).

## How do I fix CVE-2014-9684?

Upgrade glance to 11.0.0a0 or later.

## Is CVE-2014-9684 being exploited?

There is no known exploitation of CVE-2014-9684 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-5286](https://insights.sbomify.com/CVE-2015-5286/): OpenStack Image Service (Glance) allows remote authenticated users to bypass storage quota, cause denial of service (medium 6.8)
- [CVE-2015-1195](https://insights.sbomify.com/CVE-2015-1195/): OpenStack Glance v2 API unrestricted path traversal through filesystem:// scheme (medium 6.5)
- [CVE-2015-5251](https://insights.sbomify.com/CVE-2015-5251/): OpenStack Image Service (Glance) allows remote authenticated users to bypass access restrictions (medium 5.5)
- [CVE-2014-9493](https://insights.sbomify.com/CVE-2014-9493/): Path traversal in n/a (medium 5.5)
- [CVE-2016-0757](https://insights.sbomify.com/CVE-2016-0757/): OpenStack Image Service (Glance) vulnerable to Improper Access Control (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9684 and fix it if it is affected.

What it is: CVE-2014-9684 is a medium-severity denial of service vulnerability in n/a, published on 24 Feb 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-9684 in the wild and no public exploit code.

Affected packages and fixed versions:
- glance (PyPI): affected all versions; fixed in 11.0.0a0
- glance (PyPI): affected all versions; fixed in 11.0.0a0
- glance (PyPI): affected all versions; fixed in 11.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9684/ (Markdown: https://insights.sbomify.com/CVE-2014-9684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9684
- OSV: https://osv.dev/vulnerability/CVE-2014-9684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9684/
Summaries are generated and may contain mistakes; the official description above is the record.
