# CVE-2014-9706: Dulwich Arbitrary code execution via commit with directory path starting with .git

> Remote attackers can execute arbitrary code by providing a malicious commit with a .git/ directory path, affecting users of the Dulwich library.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-9706, GHSA-4j5j-58j7-6c3w, PYSEC-2015-34

## What is CVE-2014-9706?

CVE-2014-9706 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 31 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The build_index_from_tree function in index.py in Dulwich before 0.9.9 allows remote attackers to execute arbitrary code via a commit with a directory path starting with .git/, which is not properly handled when checking out a working tree.

Weakness: CWE-19

## Which versions are affected by CVE-2014-9706?

3 open source packages ship an affected version, including dulwich. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dulwich` | PyPI | All versions | 0.9.10 |
| `dulwich` | PyPI | All versions | 0.9.10 |
| `dulwich` | PyPI | All versions | 0.9.9 |

Products: Debian Debian Linux, Dulwich Project Dulwich.

## How do I fix CVE-2014-9706?

Upgrade dulwich to a fixed version for your release line: 0.9.10 or 0.9.9.

## Is CVE-2014-9706 being exploited?

There is no known exploitation of CVE-2014-9706 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9706 and fix it if it is affected.

What it is: CVE-2014-9706 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 31 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-9706 in the wild and no public exploit code.

Affected packages and fixed versions:
- dulwich (PyPI): affected all versions; fixed in 0.9.10
- dulwich (PyPI): affected all versions; fixed in 0.9.10
- dulwich (PyPI): affected all versions; fixed in 0.9.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9706/ (Markdown: https://insights.sbomify.com/CVE-2014-9706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9706
- OSV: https://osv.dev/vulnerability/CVE-2014-9706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9706/
Summaries are generated and may contain mistakes; the official description above is the record.
