{"answers":{"affected":"It affects 5 products.","exploited":"There is no known exploitation of CVE-2014-9709 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-9709 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 30 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-9709 and fix it if it is affected.\n\nWhat it is: CVE-2014-9709 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 30 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-9709 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-9709/ (Markdown: https://insights.sbomify.com/CVE-2014-9709/index.md)","id":"CVE-2014-9709","markdown":"https://insights.sbomify.com/CVE-2014-9709/index.md","name":"CVE-2014-9709","record":{"aliases":["DEBIAN-CVE-2014-9709","GHSA-p5p8-3769-2g8g","SUSE-SU-2015:0835-1","SUSE-SU-2015:0866-1","UBUNTU-CVE-2014-9709"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GD image library","requires_auth":"none","summary":"Remote attackers can cause a denial of service via a crafted GIF image processed by the GD library in PHP.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"libgd","vendor":"libgd"},{"product":"opensuse","vendor":"opensuse"},{"product":"php","vendor":"php"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"The GetCode_ function in gd_gif_in.c in GD 2.1.1 and earlier, as used in PHP before 5.5.21 and 5.6.x before 5.6.5, allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted GIF image that is improperly handled by the gdImageCreateFromGif function.","ecosystems":["SUSE:Linux Enterprise Desktop 12","SUSE:Linux Enterprise Server 12","SUSE:Linux Enterprise Server for SAP Applications 12","SUSE:Linux Enterprise Software Development Kit 12","SUSE:Linux Enterprise Workstation Extension 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2014-9709","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","opensuse:opensuse","php:php"],"type":"denial_of_service","year":"2014"},"n_packages":5,"n_references":24,"next":{"headline":"Race condition in n/a","id":"CVE-2014-9710"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12","fixed":["2.1.0-5.1"],"introduced":["0"],"last_affected":[],"package":"gd","purl":"pkg:rpm/suse/gd\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012","source":"SUSE-SU-2015:0866-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12","fixed":["2.1.0-5.1"],"introduced":["0"],"last_affected":[],"package":"gd","purl":"pkg:rpm/suse/gd\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012","source":"SUSE-SU-2015:0866-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12","fixed":["2.1.0-5.1"],"introduced":["0"],"last_affected":[],"package":"gd","purl":"pkg:rpm/suse/gd\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012","source":"SUSE-SU-2015:0866-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["2.1.0-5.1"],"introduced":["0"],"last_affected":[],"package":"gd","purl":"pkg:rpm/suse/gd\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2015:0866-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12","fixed":["2.1.0-5.1"],"introduced":["0"],"last_affected":[],"package":"gd","purl":"pkg:rpm/suse/gd\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012","source":"SUSE-SU-2015:0866-1"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2014-9708"},"products":["n/a"],"published":"2015-03-30","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via a crafted GIF image processed by the GD library in PHP.","url":"https://insights.sbomify.com/CVE-2014-9709/"}