# CVE-2014-9720: Tornado XSRF cookie allows side-channel attack against TLS (BREACH attack)

> Remote attackers can exploit HTTP compression to leak CSRF tokens via BREACH attacks, enabling potential CSRF bypasses in applications using Tornado.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jan 2020
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-9720, DLA-279-1, DLA-475-1, GHSA-8vpw-mgpf-mpvv, MGASA-2015-0251, PYSEC-2020-213, SUSE-SU-2016:1195-1

## What is CVE-2014-9720?

CVE-2014-9720 is a medium-severity vulnerability in n/a, published on 24 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Tornado before 3.2.2 sends arbitrary responses that contain a fixed CSRF token and may be sent with HTTP compression, which makes it easier for remote attackers to conduct a BREACH attack and determine this token via a series of crafted requests.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2014-9720?

3 open source packages ship an affected version, including tornado. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 3.2.2 |
| `tornado` | PyPI | All versions | 3.2.2 |
| `tornado` | PyPI | All versions | 3.2.2 |
| `python-backports.ssl_match_hostname` | SUSE:Linux Enterprise Desktop 12 | All versions | 3.4.0.2-15.1 |
| `python-tornado` | SUSE:Linux Enterprise Desktop 12 | All versions | 4.2.1-11.1 |
| `python-backports.ssl_match_hostname` | SUSE:Linux Enterprise Desktop 12 SP1 | All versions | 3.4.0.2-15.1 |
| `python-tornado` | SUSE:Linux Enterprise Desktop 12 SP1 | All versions | 4.2.1-11.1 |
| `python-backports.ssl_match_hostname` | SUSE:Linux Enterprise Workstation Extension 12 | All versions | 3.4.0.2-15.1 |
| `python-tornado` | SUSE:Linux Enterprise Workstation Extension 12 | All versions | 4.2.1-11.1 |
| `python-backports.ssl_match_hostname` | SUSE:Linux Enterprise Workstation Extension 12 SP1 | All versions | 3.4.0.2-15.1 |
| `python-tornado` | SUSE:Linux Enterprise Workstation Extension 12 SP1 | All versions | 4.2.1-11.1 |

Products: Tornadoweb Tornado.

## How do I fix CVE-2014-9720?

Upgrade tornado to 3.2.2 or later.

## Is CVE-2014-9720 being exploited?

There is no known exploitation of CVE-2014-9720 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-31958](https://insights.sbomify.com/CVE-2026-31958/): Tornado has a DoS due to too many multipart parts (high 8.7)
- [CVE-2025-67725](https://insights.sbomify.com/CVE-2025-67725/): Tornado is Vulnerable to Quadratic DoS via Repeated Header Coalescing (high 7.5)
- [CVE-2025-67726](https://insights.sbomify.com/CVE-2025-67726/): Tornado is Vulnerable to Quadratic DoS via Crafted Multipart Parameters (high 7.5)
- [CVE-2024-52804](https://insights.sbomify.com/CVE-2024-52804/): Tornado has HTTP cookie parsing DoS vulnerability (high 7.5)
- [CVE-2026-35536](https://insights.sbomify.com/CVE-2026-35536/): Tornado has incomplete validation of cookie attributes (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9720 and fix it if it is affected.

What it is: CVE-2014-9720 is a medium-severity vulnerability in n/a, published on 24 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-9720 in the wild and no public exploit code.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 3.2.2
- tornado (PyPI): affected all versions; fixed in 3.2.2
- tornado (PyPI): affected all versions; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9720/ (Markdown: https://insights.sbomify.com/CVE-2014-9720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9720
- OSV: https://osv.dev/vulnerability/CVE-2014-9720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9720/
Summaries are generated and may contain mistakes; the official description above is the record.
