{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-9721 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-9721 is a medium-severity vulnerability in n/a, published on 3 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-9721 and fix it if it is affected.\n\nWhat it is: CVE-2014-9721 is a medium-severity vulnerability in n/a, published on 3 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-9721 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-9721/ (Markdown: https://insights.sbomify.com/CVE-2014-9721/index.md)","id":"CVE-2014-9721","markdown":"https://insights.sbomify.com/CVE-2014-9721/index.md","name":"CVE-2014-9721","record":{"aliases":["DEBIAN-CVE-2014-9721","DSA-3255-1","GHSA-cx82-pq93-6p39","SUSE-SU-2015:1510-1","UBUNTU-CVE-2014-9721"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"ZeroMQ messaging library","requires_auth":"none","summary":"Remote attackers can bypass ZMTP v3 security mechanisms by forcing a downgrade to older protocol versions in the libzmq library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"zeromq","vendor":"zeromq"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"libzmq before 4.0.6 and 4.1.x before 4.1.1 allows remote attackers to conduct downgrade attacks and bypass ZMTP v3 protocol security mechanisms via a ZMTP v2 or earlier header.","ecosystems":["SUSE:Enterprise Storage 1.0","SUSE:Linux Enterprise Desktop 12","SUSE:Linux Enterprise Software Development Kit 12","SUSE:Linux Enterprise Workstation Extension 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2014-9721","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2014"},"n_packages":4,"n_references":5,"next":{"headline":"Command injection in n/a","id":"CVE-2014-9727"},"packages":[{"ecosystem":"SUSE:Enterprise Storage 1.0","fixed":["4.0.4-13.1"],"introduced":["0"],"last_affected":[],"package":"zeromq","purl":"pkg:rpm/suse/zeromq\u0026distro=SUSE%20Enterprise%20Storage%201.0","source":"SUSE-SU-2015:1510-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12","fixed":["4.0.4-13.1"],"introduced":["0"],"last_affected":[],"package":"zeromq","purl":"pkg:rpm/suse/zeromq\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012","source":"SUSE-SU-2015:1510-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["4.0.4-13.1"],"introduced":["0"],"last_affected":[],"package":"zeromq","purl":"pkg:rpm/suse/zeromq\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2015:1510-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12","fixed":["4.0.4-13.1"],"introduced":["0"],"last_affected":[],"package":"zeromq","purl":"pkg:rpm/suse/zeromq\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012","source":"SUSE-SU-2015:1510-1"}],"prev":{"headline":"Tornado XSRF cookie allows side-channel attack against TLS (BREACH attack)","id":"CVE-2014-9720"},"products":["n/a"],"published":"2015-06-03","related":[{"cvss_score":4.3,"headline":"Security feature bypass in n/a","id":"CVE-2014-7202","kev_date_added":null,"published":"2014-10-08"},{"cvss_score":4.3,"headline":"Other in n/a","id":"CVE-2014-7203","kev_date_added":null,"published":"2014-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass ZMTP v3 security mechanisms by forcing a downgrade to older protocol versions in the libzmq library.","url":"https://insights.sbomify.com/CVE-2014-9721/"}