# CVE-2014-9970: Exposure of Sensitive Information to an Unauthorized Actor in Apache Jasypt

> An attacker can exploit a timing side-channel in password hash comparison to potentially recover sensitive information.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-9970, GHSA-r5c2-rxh2-f5h2, UBUNTU-CVE-2014-9970

## What is CVE-2014-9970?

CVE-2014-9970 is a high-severity vulnerability in n/a, published on 21 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jasypt before 1.9.2 allows a timing attack against the password hash comparison.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-9970?

2 open source packages ship an affected version, including org.jasypt:jasypt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jasypt:jasypt` | Maven | All versions | 1.9.2 |
| `org.jasypt:jasypt` | Maven | All versions | 1.9.2 |

Products: Jasypt Project Jasypt.

## How do I fix CVE-2014-9970?

Upgrade org.jasypt:jasypt to 1.9.2 or later.

## Is CVE-2014-9970 being exploited?

There is no known exploitation of CVE-2014-9970 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-9970 and fix it if it is affected.

What it is: CVE-2014-9970 is a high-severity vulnerability in n/a, published on 21 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-9970 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jasypt:jasypt (Maven): affected all versions; fixed in 1.9.2
- org.jasypt:jasypt (Maven): affected all versions; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-9970/ (Markdown: https://insights.sbomify.com/CVE-2014-9970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-9970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-9970
- OSV: https://osv.dev/vulnerability/CVE-2014-9970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-9970/
Summaries are generated and may contain mistakes; the official description above is the record.
