# CVE-2015-0201: Moderate severity vulnerability that affects org.springframework:spring-core

> Predictable session IDs in the Java SockJS client allow remote attackers to send messages to other sessions, impacting data integrity and confidentiality.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-45vg-2v73-vm62

## What is CVE-2015-0201?

CVE-2015-0201 is a medium-severity vulnerability in Vmware Spring Framework, published on 10 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Java SockJS client in Pivotal Spring Framework 4.1.x before 4.1.5 generates predictable session ids, which allows remote attackers to send messages to other sessions via unspecified vectors.

Weakness: CWE-254

## Which versions are affected by CVE-2015-0201?

2 open source packages ship an affected version, including org.springframework:spring-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-core` | Maven | From 4.1.0 | 4.1.5 |
| `org.springframework:spring-core` | Maven | From 4.1.0 | 4.1.5 |

Products: Pivotal Software Spring Framework, Vmware Spring Framework.

## How do I fix CVE-2015-0201?

Upgrade org.springframework:spring-core to 4.1.5 or later.

## Is CVE-2015-0201 being exploited?

There is no known exploitation of CVE-2015-0201 in the wild and no public exploit code.

## Other vulnerabilities in Vmware Spring Framework

- [CVE-2014-0225](https://insights.sbomify.com/CVE-2014-0225/): Improper Restriction of XML External Entity Reference in Spring Framework (high 8.8)
- [CVE-2016-5007](https://insights.sbomify.com/CVE-2016-5007/): Spring Security and Spring Framework may not recognize certain paths that should be protected (high 7.5)
- [CVE-2016-9878](https://insights.sbomify.com/CVE-2016-9878/): Pivotal Spring Framework Paths provided to the ResourceServlet were not properly sanitized (high 7.5)
- [CVE-2013-6429](https://insights.sbomify.com/CVE-2013-6429/): Cross-Site Request Forgery in Spring Framework (medium 6.8)
- [CVE-2013-6430](https://insights.sbomify.com/CVE-2013-6430/): Improper Neutralization of Input During Web Page Generation in Spring Framework (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0201 and fix it if it is affected.

What it is: CVE-2015-0201 is a medium-severity vulnerability in Vmware Spring Framework, published on 10 Mar 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-0201 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-core (Maven): affected from 4.1.0; fixed in 4.1.5
- org.springframework:spring-core (Maven): affected from 4.1.0; fixed in 4.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0201/ (Markdown: https://insights.sbomify.com/CVE-2015-0201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0201
- OSV: https://osv.dev/vulnerability/CVE-2015-0201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0201/
Summaries are generated and may contain mistakes; the official description above is the record.
