CVE-2015-0211 Moodle allows attackers to obtain sensitive information

Medium 4.0 Published Updated

Authenticated users can bypass capability checks to access sensitive LTI tool information via the Ajax service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-0211?

CVE-2015-0211 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

mod/lti/ajax.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 does not consider the moodle/course:manageactivities and mod/lti:addinstance capabilities before proceeding with registered-tool list searches, which allows remote authenticated users to obtain sensitive information via requests to the LTI Ajax service.

Weakness: CWE-200

Which versions are affected by CVE-2015-0211?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.6.7
moodle/moodle PackagistAll versions2.6.7
moodle/moodle PackagistFrom 2.7.02.7.4
moodle/moodle PackagistFrom 2.7.02.7.4
moodle/moodle PackagistFrom 2.8.02.8.2
moodle/moodle PackagistFrom 2.8.02.8.2

Products include Moodle Moodle.

How do I fix CVE-2015-0211?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.7, 2.7.4 or 2.8.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2015-0211 being exploited?

There is no known exploitation of CVE-2015-0211 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-frhc-9hwc-x7j3.

Is CVE-2015-0211 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free