CVE-2015-0212 Moodle cross-site scripting (XSS) vulnerability

Low 3.5 Published Updated

Authenticated users can inject arbitrary scripts via course summaries in Moodle, potentially compromising other users' sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-0212?

CVE-2015-0212 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in course/pending.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to inject arbitrary web script or HTML via a crafted course summary.

Weakness: CWE-79

Which versions are affected by CVE-2015-0212?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.6.7
moodle/moodle PackagistAll versions2.6.7
moodle/moodle PackagistFrom 2.7.02.7.4
moodle/moodle PackagistFrom 2.7.02.7.4
moodle/moodle PackagistFrom 2.8.02.8.2
moodle/moodle PackagistFrom 2.8.02.8.2

Products include Moodle Moodle.

How do I fix CVE-2015-0212?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.7, 2.7.4 or 2.8.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-0212 being exploited?

There is no known exploitation of CVE-2015-0212 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-jj3j-mhgc-g4m4.

Is CVE-2015-0212 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free