CVE-2015-0214 Moodle allows attackers to bypass a messaging-disabled setting
Authenticated users can bypass messaging-disabled settings in Moodle via web-services requests, allowing unauthorized communication.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-0214?
CVE-2015-0214 is a medium-severity vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
message/externallib.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to bypass a messaging-disabled setting via a web-services request, as demonstrated by a people-search request.
Weakness: CWE-264
Which versions are affected by CVE-2015-0214?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.6.7 |
moodle/moodle Packagist | All versions | 2.6.7 |
moodle/moodle Packagist | From 2.7.0 | 2.7.4 |
moodle/moodle Packagist | From 2.7.0 | 2.7.4 |
moodle/moodle Packagist | From 2.8.0 | 2.8.2 |
moodle/moodle Packagist | From 2.8.0 | 2.8.2 |
Products include Moodle Moodle.
How do I fix CVE-2015-0214?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.7, 2.7.4 or 2.8.2.
Is CVE-2015-0214 being exploited?
There is no known exploitation of CVE-2015-0214 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-4jm2-c9jr-6prf.