CVE-2015-0217 Moodle allows attackers to cause a denial of service

Medium 6.8 Published Updated

Authenticated users can cause a denial of service in Moodle via a crafted string triggering excessive CPU consumption in the media filter.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-0217?

CVE-2015-0217 is a medium-severity denial of service vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

filter/mediaplugin/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to cause a denial of service (CPU consumption or partial outage) via a crafted string that is matched against an improper regular expression.

Weakness: CWE-399

Which versions are affected by CVE-2015-0217?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.6.7
moodle/moodle PackagistAll versions2.6.7
moodle/moodle PackagistFrom 2.7.02.7.4
moodle/moodle PackagistFrom 2.7.02.7.4
moodle/moodle PackagistFrom 2.8.02.8.2
moodle/moodle PackagistFrom 2.8.02.8.2

Products include Moodle Moodle.

How do I fix CVE-2015-0217?

Upgrade moodle/moodle to a fixed version for your release line: 2.6.7, 2.7.4 or 2.8.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2015-0217 being exploited?

There is no known exploitation of CVE-2015-0217 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-p497-37fc-xvvc.

Is CVE-2015-0217 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free