CVE-2015-0218 Moodle cross-site request forgery (CSRF) vulnerability
Remote attackers can force authenticated Moodle users to log out via CSRF, disrupting their sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-0218?
CVE-2015-0218 is a medium-severity vulnerability in Moodle Moodle, published on 1 Jun 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site request forgery (CSRF) vulnerability in auth/shibboleth/logout.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote attackers to hijack the authentication of arbitrary users for requests that trigger a logout.
Weakness: CWE-352
Which versions are affected by CVE-2015-0218?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.6.7 |
moodle/moodle Packagist | All versions | 2.6.7 |
moodle/moodle Packagist | From 2.7.0 | 2.7.4 |
moodle/moodle Packagist | From 2.7.0 | 2.7.4 |
moodle/moodle Packagist | From 2.8.0 | 2.8.2 |
moodle/moodle Packagist | From 2.8.0 | 2.8.2 |
Products include Moodle Moodle.
How do I fix CVE-2015-0218?
Upgrade moodle/moodle to a fixed version for your release line: 2.6.7, 2.7.4 or 2.8.2.
Is CVE-2015-0218 being exploited?
There is no known exploitation of CVE-2015-0218 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-5jph-mvfm-r27p.