CVE-2015-0219 Django WSGI Header Spoofing Vulnerability
Remote attackers can spoof WSGI headers by using underscores instead of dashes, potentially bypassing authentication or security controls in Django applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-0219?
CVE-2015-0219 is a medium-severity vulnerability in Djangoproject Django, published on 16 Jan 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 allows remote attackers to spoof WSGI headers by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X-Auth_User header.
Weakness: CWE-17
Which versions are affected by CVE-2015-0219?
7 open source packages ship an affected version, including django and Django. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.4.18, 1.6.10, 1.7.3 |
django PyPI | All versions | 1.4.18 |
django PyPI | From 1.6 | 1.6.10 |
django PyPI | From 1.7 | 1.7.3 |
Django PyPI | All versions | 1.4.18 |
Django PyPI | From 1.6 | 1.6.10 |
1 more packages
Django PyPI | From 1.7 | 1.7.3 |
Linux distribution packages (3)
python-bjoern openSUSE:Tumbleweed | All versions | 1.4.2-1.23 |
python-bjoern openSUSE:Tumbleweed | All versions | 3.2.2-1.10 |
python-bjoern openSUSE:Tumbleweed | All versions | 3.2.2-2.6 |
Products include Djangoproject Django.
How do I fix CVE-2015-0219?
Upgrade django to a fixed version for your release line: 1.4.18, 1.6.10 or 1.7.3.
Is CVE-2015-0219 being exploited?
There is no known exploitation of CVE-2015-0219 in the wild and no public exploit code.
Other vulnerabilities in Djangoproject Django
- CVE-2026-4277 Privilege abuse in GenericInlineModelAdmin
- CVE-2024-53908 Django SQL injection in HasKey(lhs, rhs) on Oracle
- CVE-2024-42005 Django SQL injection vulnerability
- CVE-2023-31047 Django bypasses validation when using one form field to upload multiple files
- CVE-2022-34265 Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection
Sources
Also known as DEBIAN-CVE-2015-0219, GHSA-7qfw-j7hp-v45g, PYSEC-2015-4, UBUNTU-CVE-2015-0219, openSUSE-SU-2024:10206-1, openSUSE-SU-2024:11218-1 and 2 more.