CVE-2015-0221 Django DoS in django.views.static.serve
Remote attackers can cause denial of service via memory consumption by exploiting inefficient file reading in Django's static view.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-0221?
CVE-2015-0221 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 16 Jan 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The django.views.static.serve view in Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 reads files an entire line at a time, which allows remote attackers to cause a denial of service (memory consumption) via a long line in a file.
Weakness: CWE-399
Which versions are affected by CVE-2015-0221?
7 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.4.18, 1.6.10, 1.7.3 |
django PyPI | All versions | 1.4.18 |
django PyPI | From 1.6 | 1.6.10 |
django PyPI | From 1.7 | 1.7.3 |
Django PyPI | All versions | 1.4.18 |
Django PyPI | From 1.6 | 1.6.10 |
1 more packages
Django PyPI | From 1.7 | 1.7.3 |
Products include Canonical Ubuntu Linux, Djangoproject Django.
How do I fix CVE-2015-0221?
Upgrade django to a fixed version for your release line: 1.4.18, 1.6.10 or 1.7.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2015-0221 being exploited?
There is no known exploitation of CVE-2015-0221 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2015-0221, GHSA-jhjg-w2cp-5j44, PYSEC-2015-6, UBUNTU-CVE-2015-0221.