CVE-2015-0222 Django database denial-of-service with ModelMultipleChoiceField
Remote attackers can cause denial of service in Django applications by submitting duplicate values to ModelMultipleChoiceField when show_hidden_initial is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-0222?
CVE-2015-0222 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 16 Jan 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ModelMultipleChoiceField in Django 1.6.x before 1.6.10 and 1.7.x before 1.7.3, when show_hidden_initial is set to True, allows remote attackers to cause a denial of service by submitting duplicate values, which triggers a large number of SQL queries.
Weakness: CWE-17
Which versions are affected by CVE-2015-0222?
5 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.4.18, 1.6.10, 1.7.3 |
django PyPI | From 1.6 | 1.6.10 |
django PyPI | From 1.7 | 1.7.3 |
Django PyPI | From 1.6 | 1.6.10 |
Django PyPI | From 1.7 | 1.7.3 |
Products include Canonical Ubuntu Linux, Djangoproject Django.
How do I fix CVE-2015-0222?
Upgrade django to a fixed version for your release line: 1.4.18, 1.6.10 or 1.7.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2015-0222 being exploited?
There is no known exploitation of CVE-2015-0222 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2015-0222, GHSA-6g95-x6cj-mg4v, PYSEC-2015-7, UBUNTU-CVE-2015-0222.