CVE-2015-0225 Improper Neutralization of Special Elements used in a Command in Apache Cassandra
Remote attackers can execute arbitrary Java code via unauthenticated RMI requests due to default network binding settings in Apache Cassandra.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-0225?
CVE-2015-0225 is a high-severity vulnerability in n/a, published on 3 Apr 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The default configuration in Apache Cassandra 1.2.0 through 1.2.19, 2.0.0 through 2.0.13, and 2.1.0 through 2.1.3 binds an unauthenticated JMX/RMI interface to all network interfaces, which allows remote attackers to execute arbitrary Java code via an RMI request.
Weakness: CWE-77
Which versions are affected by CVE-2015-0225?
4 open source packages ship an affected version, including org.apache.cassandra:apache-cassandra. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.cassandra:apache-cassandra Maven | From 1.2.0 | 2.0.14 |
org.apache.cassandra:apache-cassandra Maven | From 1.2.0 | 2.0.14 |
org.apache.cassandra:apache-cassandra Maven | From 2.1.0 | 2.1.4 |
org.apache.cassandra:apache-cassandra Maven | From 2.1.0 | 2.1.4 |
Products include Apache Cassandra.
How do I fix CVE-2015-0225?
Upgrade org.apache.cassandra:apache-cassandra to a fixed version for your release line: 2.0.14 or 2.1.4.
Is CVE-2015-0225 being exploited?
There is no known exploitation of CVE-2015-0225 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2016-3427 Oracle Java SE and JRockit Unspecified
- CVE-2018-8016 Missing Authentication for Critical Function in Apache Cassandra
- CVE-2021-44521 Remote code execution for scripted UDFs
- CVE-2026-27314 Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass
- CVE-2025-26467 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)
Sources
Also known as GHSA-w7f2-gjxf-2gm9.