# CVE-2015-0225: Improper Neutralization of Special Elements used in a Command in Apache Cassandra

> Remote attackers can execute arbitrary Java code via unauthenticated RMI requests due to default network binding settings in Apache Cassandra.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-w7f2-gjxf-2gm9

## What is CVE-2015-0225?

CVE-2015-0225 is a high-severity vulnerability in n/a, published on 3 Apr 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The default configuration in Apache Cassandra 1.2.0 through 1.2.19, 2.0.0 through 2.0.13, and 2.1.0 through 2.1.3 binds an unauthenticated JMX/RMI interface to all network interfaces, which allows remote attackers to execute arbitrary Java code via an RMI request.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2015-0225?

4 open source packages ship an affected version, including org.apache.cassandra:apache-cassandra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cassandra:apache-cassandra` | Maven | From 1.2.0 | 2.0.14 |
| `org.apache.cassandra:apache-cassandra` | Maven | From 1.2.0 | 2.0.14 |
| `org.apache.cassandra:apache-cassandra` | Maven | From 2.1.0 | 2.1.4 |
| `org.apache.cassandra:apache-cassandra` | Maven | From 2.1.0 | 2.1.4 |

Products: Apache Cassandra.

## How do I fix CVE-2015-0225?

Upgrade org.apache.cassandra:apache-cassandra to a fixed version for your release line: 2.0.14 or 2.1.4.

## Is CVE-2015-0225 being exploited?

There is no known exploitation of CVE-2015-0225 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-3427](https://insights.sbomify.com/CVE-2016-3427/): Oracle Java SE and JRockit Unspecified (critical 9.8, exploited in the wild)
- [CVE-2018-8016](https://insights.sbomify.com/CVE-2018-8016/): Missing Authentication for Critical Function in Apache Cassandra (critical 9.8)
- [CVE-2021-44521](https://insights.sbomify.com/CVE-2021-44521/): Remote code execution for scripted UDFs (critical 9.1)
- [CVE-2026-27314](https://insights.sbomify.com/CVE-2026-27314/): Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass (high 8.8)
- [CVE-2025-26467](https://insights.sbomify.com/CVE-2025-26467/): Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0225 and fix it if it is affected.

What it is: CVE-2015-0225 is a high-severity vulnerability in n/a, published on 3 Apr 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-0225 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cassandra:apache-cassandra (Maven): affected from 1.2.0; fixed in 2.0.14
- org.apache.cassandra:apache-cassandra (Maven): affected from 1.2.0; fixed in 2.0.14
- org.apache.cassandra:apache-cassandra (Maven): affected from 2.1.0; fixed in 2.1.4
- org.apache.cassandra:apache-cassandra (Maven): affected from 2.1.0; fixed in 2.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0225/ (Markdown: https://insights.sbomify.com/CVE-2015-0225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0225
- OSV: https://osv.dev/vulnerability/CVE-2015-0225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0225/
Summaries are generated and may contain mistakes; the official description above is the record.
