# CVE-2015-0226: Use of a Broken or Risky Cryptographic Algorithm in Apache WSS4J

> Remote attackers can recover symmetric key plaintext via crafted messages due to improper decryption failure information leakage in Apache WSS4J.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-0226, GHSA-vjwc-5hfh-2vv5

## What is CVE-2015-0226?

CVE-2015-0226 is a high-severity vulnerability in n/a, published on 30 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache WSS4J before 1.6.17 and 2.0.x before 2.0.2 improperly leaks information about decryption failures when decrypting an encrypted key or message data, which makes it easier for remote attackers to recover the plaintext form of a symmetric key via a series of crafted messages. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-2487.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2015-0226?

4 open source packages ship an affected version, including org.apache.ws.security:wss4j and org.apache.wss4j:wss4j-ws-security-dom. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ws.security:wss4j` | Maven | All versions | 1.6.17 |
| `org.apache.ws.security:wss4j` | Maven | All versions | 1.6.17 |
| `org.apache.wss4j:wss4j-ws-security-dom` | Maven | From 2.0.0 | 2.0.2 |
| `org.apache.wss4j:wss4j-ws-security-dom` | Maven | From 2.0.0 | 2.0.2 |

Products: Apache Wss4j.

## How do I fix CVE-2015-0226?

Upgrade org.apache.ws.security:wss4j to 1.6.17 or later.

## Is CVE-2015-0226 being exploited?

There is no known exploitation of CVE-2015-0226 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-88920](https://insights.sbomify.com/CVE-2026-88920/): Apache WSS4J: SAML Sender-Vouches Authentication Bypass (critical 9.8)
- [CVE-2026-87830](https://insights.sbomify.com/CVE-2026-87830/): Apache WSS4J: Streaming WS-SecurityPolicy validation may skip element-protection checks. (critical 9.1)
- [CVE-2026-89238](https://insights.sbomify.com/CVE-2026-89238/): Apache WSS4J: WSS4J EncryptedHeader child confusion causing wrong protected-header selection (critical 9.1)
- [CVE-2026-85532](https://insights.sbomify.com/CVE-2026-85532/): Apache WSS4J: Insufficient Validation of Derived-Key Parameters (high 7.5)
- [CVE-2026-92121](https://insights.sbomify.com/CVE-2026-92121/): Apache WSS4J: WS-SecurityPolicy signature checks skipped in the streaming code after an STR-Transform reference (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0226 and fix it if it is affected.

What it is: CVE-2015-0226 is a high-severity vulnerability in n/a, published on 30 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-0226 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ws.security:wss4j (Maven): affected all versions; fixed in 1.6.17
- org.apache.ws.security:wss4j (Maven): affected all versions; fixed in 1.6.17
- org.apache.wss4j:wss4j-ws-security-dom (Maven): affected from 2.0.0; fixed in 2.0.2
- org.apache.wss4j:wss4j-ws-security-dom (Maven): affected from 2.0.0; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0226/ (Markdown: https://insights.sbomify.com/CVE-2015-0226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0226
- OSV: https://osv.dev/vulnerability/CVE-2015-0226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0226/
Summaries are generated and may contain mistakes; the official description above is the record.
