CVE-2015-0227 Improper Access Control in Apache WSS4J

Medium 5.0 Published Updated

Remote attackers can bypass signed and encrypted data requirements in Apache WSS4J via wrapping attacks, compromising security controls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-0227?

CVE-2015-0227 is a medium-severity vulnerability in n/a, published on 12 Feb 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a vectors related to "wrapping attacks."

Weakness: CWE-264

Which versions are affected by CVE-2015-0227?

6 open source packages ship an affected version, including org.apache.ws.security:wss4j and wss4j:wss4j. It affects 1 product.

PackageAffectedFixed in
org.apache.ws.security:wss4j MavenAll versions1.6.17
org.apache.ws.security:wss4j MavenAll versions1.6.17
org.apache.ws.security:wss4j MavenFrom 2.0.02.02
org.apache.ws.security:wss4j MavenFrom 2.0.02.02
wss4j:wss4j MavenAll versions1.6.17
wss4j:wss4j MavenAll versions1.6.17

Products include Apache Wss4j.

How do I fix CVE-2015-0227?

Upgrade org.apache.ws.security:wss4j to a fixed version for your release line: 1.6.17 or 2.02.

Is CVE-2015-0227 being exploited?

There is no known exploitation of CVE-2015-0227 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2015-0227, GHSA-6r5v-hp32-fjqw.

Is CVE-2015-0227 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free