{"answers":{"affected":"6 open source packages ship an affected version, including org.apache.ws.security:wss4j and wss4j:wss4j. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-0227 in the wild and no public exploit code.","fix":"Upgrade org.apache.ws.security:wss4j to a fixed version for your release line: 1.6.17 or 2.02.","what":"CVE-2015-0227 is a medium-severity vulnerability in n/a, published on 12 Feb 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-0227 and fix it if it is affected.\n\nWhat it is: CVE-2015-0227 is a medium-severity vulnerability in n/a, published on 12 Feb 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-0227 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.ws.security:wss4j (Maven): affected all versions; fixed in 1.6.17\n- org.apache.ws.security:wss4j (Maven): affected all versions; fixed in 1.6.17\n- org.apache.ws.security:wss4j (Maven): affected from 2.0.0; fixed in 2.02\n- org.apache.ws.security:wss4j (Maven): affected from 2.0.0; fixed in 2.02\n- wss4j:wss4j (Maven): affected all versions; fixed in 1.6.17\n- wss4j:wss4j (Maven): affected all versions; fixed in 1.6.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-0227/ (Markdown: https://insights.sbomify.com/CVE-2015-0227/index.md)","id":"CVE-2015-0227","markdown":"https://insights.sbomify.com/CVE-2015-0227/index.md","name":"CVE-2015-0227","record":{"aliases":["DEBIAN-CVE-2015-0227","GHSA-6r5v-hp32-fjqw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Java security library","requires_auth":"none","summary":"Remote attackers can bypass signed and encrypted data requirements in Apache WSS4J via wrapping attacks, compromising security controls.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"wss4j","vendor":"apache"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a vectors related to \"wrapping attacks.\"","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Access Control in Apache WSS4J","id":"CVE-2015-0227","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2015"},"n_packages":6,"n_references":12,"next":{"headline":"Denial of service in n/a","id":"CVE-2015-0228"},"packages":[{"ecosystem":"Maven","fixed":["1.6.17"],"introduced":["0"],"last_affected":[],"package":"org.apache.ws.security:wss4j","purl":null,"source":"GHSA-6r5v-hp32-fjqw"},{"ecosystem":"Maven","fixed":["1.6.17"],"introduced":["0"],"last_affected":[],"package":"org.apache.ws.security:wss4j","purl":"pkg:maven/org.apache.ws.security/wss4j","source":"GHSA-6r5v-hp32-fjqw"},{"ecosystem":"Maven","fixed":["2.02"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.ws.security:wss4j","purl":null,"source":"GHSA-6r5v-hp32-fjqw"},{"ecosystem":"Maven","fixed":["2.02"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.ws.security:wss4j","purl":"pkg:maven/org.apache.ws.security/wss4j","source":"GHSA-6r5v-hp32-fjqw"},{"ecosystem":"Maven","fixed":["1.6.17"],"introduced":["0"],"last_affected":[],"package":"wss4j:wss4j","purl":null,"source":"GHSA-6r5v-hp32-fjqw"},{"ecosystem":"Maven","fixed":["1.6.17"],"introduced":["0"],"last_affected":[],"package":"wss4j:wss4j","purl":"pkg:maven/wss4j/wss4j","source":"GHSA-6r5v-hp32-fjqw"}],"prev":{"headline":"Use of a Broken or Risky Cryptographic Algorithm in Apache WSS4J","id":"CVE-2015-0226"},"products":["n/a"],"published":"2015-02-12","related":[{"cvss_score":9.8,"headline":"Apache WSS4J: SAML Sender-Vouches Authentication Bypass","id":"CVE-2026-88920","kev_date_added":null,"published":"2026-09-30"},{"cvss_score":9.1,"headline":"Apache WSS4J: Streaming WS-SecurityPolicy validation may skip element-protection checks.","id":"CVE-2026-87830","kev_date_added":null,"published":"2026-09-30"},{"cvss_score":9.1,"headline":"Apache WSS4J: WSS4J EncryptedHeader child confusion causing wrong protected-header selection","id":"CVE-2026-89238","kev_date_added":null,"published":"2026-09-30"},{"cvss_score":7.5,"headline":"Apache WSS4J: Insufficient Validation of Derived-Key Parameters","id":"CVE-2026-85532","kev_date_added":null,"published":"2026-09-30"},{"cvss_score":7.5,"headline":"Apache WSS4J: WS-SecurityPolicy signature checks skipped in the streaming code after an STR-Transform reference","id":"CVE-2026-92121","kev_date_added":null,"published":"2026-09-30"},{"cvss_score":7.5,"headline":"Apache WSS4J: Unauthenticated denial of service via integer overflow in DER parsing of X.509 certificate extensions","id":"CVE-2026-95616","kev_date_added":null,"published":"2026-09-30"},{"cvss_score":7.5,"headline":"Use of a Broken or Risky Cryptographic Algorithm in Apache WSS4J","id":"CVE-2015-0226","kev_date_added":null,"published":"2017-10-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass signed and encrypted data requirements in Apache WSS4J via wrapping attacks, compromising security controls.","url":"https://insights.sbomify.com/CVE-2015-0227/"}