# CVE-2015-0227: Improper Access Control in Apache WSS4J

> Remote attackers can bypass signed and encrypted data requirements in Apache WSS4J via wrapping attacks, compromising security controls.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-0227, GHSA-6r5v-hp32-fjqw

## What is CVE-2015-0227?

CVE-2015-0227 is a medium-severity vulnerability in n/a, published on 12 Feb 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache WSS4J before 1.6.17 and 2.x before 2.0.2 allows remote attackers to bypass the requireSignedEncryptedDataElements configuration via a vectors related to "wrapping attacks."

Weakness: CWE-264

## Which versions are affected by CVE-2015-0227?

6 open source packages ship an affected version, including org.apache.ws.security:wss4j and wss4j:wss4j. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ws.security:wss4j` | Maven | All versions | 1.6.17 |
| `org.apache.ws.security:wss4j` | Maven | All versions | 1.6.17 |
| `org.apache.ws.security:wss4j` | Maven | From 2.0.0 | 2.02 |
| `org.apache.ws.security:wss4j` | Maven | From 2.0.0 | 2.02 |
| `wss4j:wss4j` | Maven | All versions | 1.6.17 |
| `wss4j:wss4j` | Maven | All versions | 1.6.17 |

Products: Apache Wss4j.

## How do I fix CVE-2015-0227?

Upgrade org.apache.ws.security:wss4j to a fixed version for your release line: 1.6.17 or 2.02.

## Is CVE-2015-0227 being exploited?

There is no known exploitation of CVE-2015-0227 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-88920](https://insights.sbomify.com/CVE-2026-88920/): Apache WSS4J: SAML Sender-Vouches Authentication Bypass (critical 9.8)
- [CVE-2026-87830](https://insights.sbomify.com/CVE-2026-87830/): Apache WSS4J: Streaming WS-SecurityPolicy validation may skip element-protection checks. (critical 9.1)
- [CVE-2026-89238](https://insights.sbomify.com/CVE-2026-89238/): Apache WSS4J: WSS4J EncryptedHeader child confusion causing wrong protected-header selection (critical 9.1)
- [CVE-2026-85532](https://insights.sbomify.com/CVE-2026-85532/): Apache WSS4J: Insufficient Validation of Derived-Key Parameters (high 7.5)
- [CVE-2026-92121](https://insights.sbomify.com/CVE-2026-92121/): Apache WSS4J: WS-SecurityPolicy signature checks skipped in the streaming code after an STR-Transform reference (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0227 and fix it if it is affected.

What it is: CVE-2015-0227 is a medium-severity vulnerability in n/a, published on 12 Feb 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-0227 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ws.security:wss4j (Maven): affected all versions; fixed in 1.6.17
- org.apache.ws.security:wss4j (Maven): affected all versions; fixed in 1.6.17
- org.apache.ws.security:wss4j (Maven): affected from 2.0.0; fixed in 2.02
- org.apache.ws.security:wss4j (Maven): affected from 2.0.0; fixed in 2.02
- wss4j:wss4j (Maven): affected all versions; fixed in 1.6.17
- wss4j:wss4j (Maven): affected all versions; fixed in 1.6.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0227/ (Markdown: https://insights.sbomify.com/CVE-2015-0227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0227
- OSV: https://osv.dev/vulnerability/CVE-2015-0227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0227/
Summaries are generated and may contain mistakes; the official description above is the record.
