{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-0245 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-0245 is a low-severity vulnerability in Opensuse Opensuse, published on 13 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-0245 and fix it if it is affected.\n\nWhat it is: CVE-2015-0245 is a low-severity vulnerability in Opensuse Opensuse, published on 13 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-0245 in the wild and no public exploit code.\n\nAffected product: Opensuse Opensuse. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-0245/ (Markdown: https://insights.sbomify.com/CVE-2015-0245/index.md)","id":"CVE-2015-0245","markdown":"https://insights.sbomify.com/CVE-2015-0245/index.md","name":"CVE-2015-0245","record":{"aliases":["DEBIAN-CVE-2015-0245","DSA-3161-1","GHSA-8jc2-f36v-gc57","MGASA-2015-0071","SUSE-SU-2015:0457-1","UBUNTU-CVE-2015-0245","USN-3116-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"D-Bus IPC system","requires_auth":"low_privilege","summary":"Local attackers can cause a denial of service in D-Bus by exploiting a race condition in ActivationFailure signal validation.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"dbus","vendor":"freedesktop"},{"product":"opensuse","vendor":"opensuse"}],"cvss":{"score":1.9,"severity":"low","source":"nvd","vector":"AV:L/AC:M/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"D-Bus 1.4.x through 1.6.x before 1.6.30, 1.8.x before 1.8.16, and 1.9.x before 1.9.10 does not validate the source of ActivationFailure signals, which allows local users to cause a denial of service (activation failure error returned) by leveraging a race condition involving sending an ActivationFailure signal before systemd responds.","ecosystems":["SUSE:Linux Enterprise Desktop 12","SUSE:Linux Enterprise Server 12","SUSE:Linux Enterprise Server for SAP Applications 12","SUSE:Linux Enterprise Software Development Kit 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Race condition in n/a","id":"CVE-2015-0245","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:opensuse","products":["opensuse:opensuse"],"type":"race_condition","year":"2015"},"n_packages":8,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-0247"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12","fixed":["1.8.16-14.1"],"introduced":["0"],"last_affected":[],"package":"dbus-1","purl":"pkg:rpm/suse/dbus-1\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012","source":"SUSE-SU-2015:0457-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12","fixed":["1.8.16-14.1"],"introduced":["0"],"last_affected":[],"package":"dbus-1-x11","purl":"pkg:rpm/suse/dbus-1-x11\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012","source":"SUSE-SU-2015:0457-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12","fixed":["1.8.16-14.1"],"introduced":["0"],"last_affected":[],"package":"dbus-1","purl":"pkg:rpm/suse/dbus-1\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012","source":"SUSE-SU-2015:0457-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12","fixed":["1.8.16-14.1"],"introduced":["0"],"last_affected":[],"package":"dbus-1-x11","purl":"pkg:rpm/suse/dbus-1-x11\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012","source":"SUSE-SU-2015:0457-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12","fixed":["1.8.16-14.1"],"introduced":["0"],"last_affected":[],"package":"dbus-1","purl":"pkg:rpm/suse/dbus-1\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012","source":"SUSE-SU-2015:0457-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12","fixed":["1.8.16-14.1"],"introduced":["0"],"last_affected":[],"package":"dbus-1-x11","purl":"pkg:rpm/suse/dbus-1-x11\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012","source":"SUSE-SU-2015:0457-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["1.8.16-14.1"],"introduced":["0"],"last_affected":[],"package":"dbus-1","purl":"pkg:rpm/suse/dbus-1\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2015:0457-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["1.8.16-14.1"],"introduced":["0"],"last_affected":[],"package":"dbus-1-x11","purl":"pkg:rpm/suse/dbus-1-x11\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2015:0457-1"}],"prev":{"headline":"SQL injection in PostgreSQL","id":"CVE-2015-0244"},"products":["n/a"],"published":"2015-02-13","related":[{"cvss_score":7.8,"headline":"Use after free in D-Bus Development branch","id":"CVE-2020-35512","kev_date_added":null,"published":"2021-02-15"},{"cvss_score":4.6,"headline":"Security feature bypass in n/a","id":"CVE-2008-4311","kev_date_added":null,"published":"2008-12-10"},{"cvss_score":3.6,"headline":"Other in n/a","id":"CVE-2009-1189","kev_date_added":null,"published":"2009-04-27"},{"cvss_score":3.3,"headline":"Path traversal in n/a","id":"CVE-2011-2533","kev_date_added":null,"published":"2011-06-22"},{"cvss_score":2.1,"headline":"Denial of service in n/a","id":"CVE-2014-3637","kev_date_added":null,"published":"2014-09-22"},{"cvss_score":2.1,"headline":"Denial of service in n/a","id":"CVE-2008-3834","kev_date_added":null,"published":"2008-10-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can cause a denial of service in D-Bus by exploiting a race condition in ActivationFailure signal validation.","url":"https://insights.sbomify.com/CVE-2015-0245/"}