# CVE-2015-0250: Improper Input Validation in Apache Batik

> Remote attackers can read arbitrary files or cause denial of service via crafted SVG files in Apache Batik, requiring user interaction to process the file.

- **Severity:** Medium 6.4 (`AV:N/AC:L/Au:N/C:P/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Mar 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-0250, DLA-182-1, DSA-3205-1, GHSA-wfw6-mmmp-87xm, MGASA-2015-0138, UBUNTU-CVE-2015-0250, USN-2548-1

## What is CVE-2015-0250?

CVE-2015-0250 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 24 Mar 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XML external entity (XXE) vulnerability in the SVG to (1) PNG and (2) JPG conversion classes in Apache Batik 1.x before 1.8 allows remote attackers to read arbitrary files or cause a denial of service via a crafted SVG file.

## Which versions are affected by CVE-2015-0250?

2 open source packages ship an affected version, including org.apache.xmlgraphics:batik. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.xmlgraphics:batik` | Maven | From 1.0 | 1.8 |
| `org.apache.xmlgraphics:batik` | Maven | From 1.0 | 1.8 |

Products: Apache Batik, Canonical Ubuntu Linux, Redhat Jboss Enterprise Brms Platform.

## How do I fix CVE-2015-0250?

Upgrade org.apache.xmlgraphics:batik to 1.8 or later.

## Is CVE-2015-0250 being exploited?

There is no known exploitation of CVE-2015-0250 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2018-8013](https://insights.sbomify.com/CVE-2018-8013/): Deserialization of Untrusted Data in Apache Batik (critical 9.8)
- [CVE-2020-11987](https://insights.sbomify.com/CVE-2020-11987/): Server-side request forgery (SSRF) in Apache Batik (high 8.2)
- [CVE-2022-41704](https://insights.sbomify.com/CVE-2022-41704/): Apache Batik prior to 1.16 allows RCE when loading untrusted SVG input (high 7.5)
- [CVE-2022-42890](https://insights.sbomify.com/CVE-2022-42890/): Apache Batik prior to 1.16 allows RCE via scripting (high 7.5)
- [CVE-2022-40146](https://insights.sbomify.com/CVE-2022-40146/): Jar url should be blocked by DefaultScriptSecurity (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0250 and fix it if it is affected.

What it is: CVE-2015-0250 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 24 Mar 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-0250 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.xmlgraphics:batik (Maven): affected from 1.0; fixed in 1.8
- org.apache.xmlgraphics:batik (Maven): affected from 1.0; fixed in 1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0250/ (Markdown: https://insights.sbomify.com/CVE-2015-0250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0250
- OSV: https://osv.dev/vulnerability/CVE-2015-0250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0250/
Summaries are generated and may contain mistakes; the official description above is the record.
