CVE-2015-0259 OpenStack Compute (Nova) has Insufficient Verification of Data Authenticity

Medium 5.1 Published Updated

Remote attackers can hijack user authentication for console access via crafted webpages due to missing websocket origin validation in OpenStack Nova.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-0259?

CVE-2015-0259 is a medium-severity vulnerability in n/a, published on 1 Apr 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

OpenStack Compute (Nova) before 2014.1.4, 2014.2.x before 2014.2.3, and kilo before kilo-3 does not validate the origin of websocket requests, which allows remote attackers to hijack the authentication of users for access to consoles via a crafted webpage.

Weakness: CWE-345

Which versions are affected by CVE-2015-0259?

5 open source packages ship an affected version, including nova. It affects 1 product.

PackageAffectedFixed in
nova PyPIAll versions2014.1.4, 2014.2.3
nova PyPIAll versions2014.1.4
nova PyPIAll versions2014.1.4
nova PyPIFrom 2014.2.02014.2.3
nova PyPIFrom 2014.2.02014.2.3
Linux distribution packages (30)
openstack-nova Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-api Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-cells Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-cert Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-common Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-compute Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-conductor Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-console Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-doc Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-network Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-novncproxy Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-objectstore Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-scheduler Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-nova-serialproxy Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
python-nova Red Hat:openstack:6::el7All versions0:2014.2.2-19.el7ost
openstack-ceilometer SUSE:Cloud Compute Node for SUSE Linux Enterprise 12 5All versions2014.2.4.dev18-3.2
openstack-neutron SUSE:Cloud Compute Node for SUSE Linux Enterprise 12 5All versions2014.2.4~a0~dev78-7.2
openstack-nova SUSE:Cloud Compute Node for SUSE Linux Enterprise 12 5All versions2014.2.4~a0~dev61-6.2
openstack-suse SUSE:Cloud Compute Node for SUSE Linux Enterprise 12 5All versions2014.2-5.1
crowbar-barclamp-ceilometer SUSE:OpenStack Cloud 5All versions1.9+git.1438201205.04a7436-9.8
crowbar-barclamp-cinder SUSE:OpenStack Cloud 5All versions1.9+git.1438200979.c385b03-10.8
crowbar-barclamp-hyperv SUSE:OpenStack Cloud 5All versions1.9+git.1432022529.1952009-10.8
crowbar-barclamp-keystone SUSE:OpenStack Cloud 5All versions1.9+git.1438197158.e32ec9e-10.7
crowbar-barclamp-neutron SUSE:OpenStack Cloud 5All versions1.9+git.1438265717.eb633ae-9.8
crowbar-barclamp-nova SUSE:OpenStack Cloud 5All versions1.9+git.1438201051.f8b5f34-9.8
openstack-neutron SUSE:OpenStack Cloud 5All versions2014.2.4~a0~dev78-13.4
openstack-neutron-doc SUSE:OpenStack Cloud 5All versions2014.2.4~a0~dev78-13.9
openstack-nova SUSE:OpenStack Cloud 5All versions2014.2.4~a0~dev61-11.4
openstack-nova-doc SUSE:OpenStack Cloud 5All versions2014.2.4~a0~dev61-11.4
openstack-resource-agents SUSE:OpenStack Cloud 5All versions1.0+git.1417010594.e813e10-9.2

Products include Openstack Nova.

How do I fix CVE-2015-0259?

Upgrade nova to a fixed version for your release line: 2014.1.4 or 2014.2.3.

Is CVE-2015-0259 being exploited?

There is no known exploitation of CVE-2015-0259 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2015-0259, GHSA-x8xr-rm9r-7mvf, PYSEC-2026-883, RHSA-2015:0790, SUSE-RU-2015:1730-1, SUSE-SU-2015:1666-1.

Is CVE-2015-0259 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free