# CVE-2015-0259: OpenStack Compute (Nova) has Insufficient Verification of Data Authenticity

> Remote attackers can hijack user authentication for console access via crafted webpages due to missing websocket origin validation in OpenStack Nova.

- **Severity:** Medium 5.1 (`AV:N/AC:H/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Apr 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-0259, GHSA-x8xr-rm9r-7mvf, PYSEC-2026-883, RHSA-2015:0790, SUSE-RU-2015:1730-1, SUSE-SU-2015:1666-1

## What is CVE-2015-0259?

CVE-2015-0259 is a medium-severity vulnerability in n/a, published on 1 Apr 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenStack Compute (Nova) before 2014.1.4, 2014.2.x before 2014.2.3, and kilo before kilo-3 does not validate the origin of websocket requests, which allows remote attackers to hijack the authentication of users for access to consoles via a crafted webpage.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2015-0259?

5 open source packages ship an affected version, including nova. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | All versions | 2014.1.4, 2014.2.3 |
| `nova` | PyPI | All versions | 2014.1.4 |
| `nova` | PyPI | All versions | 2014.1.4 |
| `nova` | PyPI | From 2014.2.0 | 2014.2.3 |
| `nova` | PyPI | From 2014.2.0 | 2014.2.3 |
| `openstack-nova` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-api` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-cells` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-cert` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-common` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-compute` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-conductor` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-console` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-doc` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-network` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-novncproxy` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-objectstore` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-scheduler` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-nova-serialproxy` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `python-nova` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.2-19.el7ost |
| `openstack-ceilometer` | SUSE:Cloud Compute Node for SUSE Linux Enterprise 12 5 | All versions | 2014.2.4.dev18-3.2 |
| `openstack-neutron` | SUSE:Cloud Compute Node for SUSE Linux Enterprise 12 5 | All versions | 2014.2.4~a0~dev78-7.2 |
| `openstack-nova` | SUSE:Cloud Compute Node for SUSE Linux Enterprise 12 5 | All versions | 2014.2.4~a0~dev61-6.2 |
| `openstack-suse` | SUSE:Cloud Compute Node for SUSE Linux Enterprise 12 5 | All versions | 2014.2-5.1 |
| `crowbar-barclamp-ceilometer` | SUSE:OpenStack Cloud 5 | All versions | 1.9+git.1438201205.04a7436-9.8 |
| `crowbar-barclamp-cinder` | SUSE:OpenStack Cloud 5 | All versions | 1.9+git.1438200979.c385b03-10.8 |
| `crowbar-barclamp-hyperv` | SUSE:OpenStack Cloud 5 | All versions | 1.9+git.1432022529.1952009-10.8 |
| `crowbar-barclamp-keystone` | SUSE:OpenStack Cloud 5 | All versions | 1.9+git.1438197158.e32ec9e-10.7 |
| `crowbar-barclamp-neutron` | SUSE:OpenStack Cloud 5 | All versions | 1.9+git.1438265717.eb633ae-9.8 |
| `crowbar-barclamp-nova` | SUSE:OpenStack Cloud 5 | All versions | 1.9+git.1438201051.f8b5f34-9.8 |
| `openstack-neutron` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4~a0~dev78-13.4 |
| `openstack-neutron-doc` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4~a0~dev78-13.9 |
| `openstack-nova` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4~a0~dev61-11.4 |
| `openstack-nova-doc` | SUSE:OpenStack Cloud 5 | All versions | 2014.2.4~a0~dev61-11.4 |
| `openstack-resource-agents` | SUSE:OpenStack Cloud 5 | All versions | 1.0+git.1417010594.e813e10-9.2 |

Products: Openstack Nova.

## How do I fix CVE-2015-0259?

Upgrade nova to a fixed version for your release line: 2014.1.4 or 2014.2.3.

## Is CVE-2015-0259 being exploited?

There is no known exploitation of CVE-2015-0259 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-7214](https://insights.sbomify.com/CVE-2017-7214/): OpenStack Nova logs sensitive context from notification exceptions (critical 9.8)
- [CVE-2017-17051](https://insights.sbomify.com/CVE-2017-17051/): OpenStack Nova DoS by rebuilding the same instance with a new image multiple times (high 8.6)
- [CVE-2020-17376](https://insights.sbomify.com/CVE-2020-17376/): OpenStack Nova Live migration fails to update persistent domain XML (high 8.3)
- [CVE-2017-18191](https://insights.sbomify.com/CVE-2017-18191/): OpenStack Nova Denial of service attack on the compute host (high 7.5)
- [CVE-2015-3280](https://insights.sbomify.com/CVE-2015-3280/): OpenStack Compute (nova) allows remote authenticated users to cause a denial of service (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-0259 and fix it if it is affected.

What it is: CVE-2015-0259 is a medium-severity vulnerability in n/a, published on 1 Apr 2015. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-0259 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected all versions; fixed in 2014.1.4, 2014.2.3
- nova (PyPI): affected all versions; fixed in 2014.1.4
- nova (PyPI): affected all versions; fixed in 2014.1.4
- nova (PyPI): affected from 2014.2.0; fixed in 2014.2.3
- nova (PyPI): affected from 2014.2.0; fixed in 2014.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-0259/ (Markdown: https://insights.sbomify.com/CVE-2015-0259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-0259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-0259
- OSV: https://osv.dev/vulnerability/CVE-2015-0259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-0259/
Summaries are generated and may contain mistakes; the official description above is the record.
